During secondary validation - DNS problem: networking error looking up A

I know same topic is already posted and answered. Well, I don't find any solution for my problem so posting here.

Tried solving issue after reading this topic: During secondary validation - DNS problem: networking error looking up A but unfortunately didn't work.

Meanwhile I generated certificate using Wild Card solution. But afraid for renewal. It may stop generating certificate on renewal time.

My domain is: www.homeindiainfratech.com

I ran this command: certbot -d www.homeindiainfratech.com --nginx

It produced this output:

Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.homeindiainfratech.com
Waiting for verification...
Challenge failed for domain www.homeindiainfratech.com
http-01 challenge for www.homeindiainfratech.com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: www.homeindiainfratech.com
   Type:   dns
   Detail: During secondary validation: DNS problem: networking error
   looking up A for www.homeindiainfratech.com

My web server is (include version): nginx/1.18.0 (Ubuntu)

nginx version: nginx/1.18.0 (Ubuntu)
built with OpenSSL 1.1.1  11 Sep 2018 (running with OpenSSL 1.1.1f  31 Mar 2020)
TLS SNI support enabled

The operating system my web server runs on is (include version): Ubuntu 20.04.1 LTS

Distributor ID: Ubuntu
Description:    Ubuntu 20.04.1 LTS
Release:        20.04
Codename:       focal

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

Hi @vinai

checking your domain via homeindiainfratech.com - Make your website better - DNS, redirects, mixed content, certificates you use Digitalocean name servers.

Normally, these name servers are ok, not buggy.

-->> networking error looks like a temporary Letsencrypt problem -->> try it again.

PS: Currently your domain has only timeouts, so http validation will not work. But that's not your dns error.

Thank you @JuergenAuer

Yes, my server was down for a moment while upgrading.

Now it is fixed and certificate generated successfully.
The problem was NS propagation of my domain. To fix this I used Googl's DNS Flush "Flush Cache  |  Public DNS  |  Google Developers". After that Lets Encrypt successfully generated certificate.

So, it was clearly not Lets encrypt problem

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.