Double autentication


#1

My domain is:

goo.gl/Jkd9V1

I ran this command:

My hosting has the possibility to select the let’s encrypt certificate and put it into the website automatically.
Unfortunately, when I do it, you send me this request:

It produced this output:

You have requested a free Let’s Encrypt certificate. Before the certificate is issued, further authentication is required. Please choose an authentication method below and do not make any changes to the values. You can remove the created entries or files once you have been issued your certificate.

  • File-based authentication: Please save text files under the path shown and copy the content into these files (without any whitespaces):

  • http://************.com/.well-known/acme-challenge/901Avppx_AU4J010IqFey2DKndGY0rQp_aQgh4sdtTc
    901Avppx_AU4J010IqFey2DKndGY0rQp_aQgh4sdtTc.5DPbktYW_pECnU0KSRIu3Xt1ZFnPoXSt1XQ3sBExCsA

  • DNS-based authentication: Please add the following DNS entries (as TXT records!) to your domain’s zonefile:

  • _acme-challenge.****************.com. IN TXT "hgJQ6KvkEvlJgr6J3tKc8VKMVZTV29btyOc6NcMtdk8"

Important note: Your order will be valid for up to 7 days. If you do not successfully authenticate your certificate within 7 days, your order will be automatically deleted.

My web server is (include version):

The operating system my web server runs on is (include version):

Linux - Apache

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

KonsoleH

Thanks


#2

What exactly is your question? The request clearly says: “Please choose an authentication method below (…)”


#3

Thanks for reply.
I don’t understand what does it mean and why I have to do this second autenthication method.

  • File-based authentication: Please save text files under the path shown and copy the content into these files (without any whitespaces):
  • http://************.com/.well-known/acme-challenge/901Avppx_AU4J010IqFey2DKndGY0rQp_aQgh4sdtTc
    901Avppx_AU4J010IqFey2DKndGY0rQp_aQgh4sdtTc.5DPbktYW_pECnU0KSRIu3Xt1ZFnPoXSt1XQ3sBExCsA

Where is the directory?

What is the name of the text file?

What is the content of this text file?

thanks


#4

Instructions are quite confusing indeed.

You need to put

901Avppx_AU4J010IqFey2DKndGY0rQp_aQgh4sdtTc.5DPbktYW_pECnU0KSRIu3Xt1ZFnPoXSt1XQ3sBExCsA

in a file named

901Avppx_AU4J010IqFey2DKndGY0rQp_aQgh4sdtTc

In .well-known/acme-challenge folder under the “root” directory of your site.

To verify you did everything right, fetching http://************.com/.well-known/acme-challenge/901Avppx_AU4J010IqFey2DKndGY0rQp_aQgh4sdtTc in a browser, should return aforementioned string back.


#5

Ok thanks this works, but I have a problem because you don’t accept the autenthication of the other website:

File-based authentication : Please save text files under the URL(s) shown and copy each content into these files (without any whitespaces):

I think I did it correctly

Can you check and help me please?

Many thanks


#6

Looks correct. What kind of error do you get during this process?


#7

Iget this error:

Unfortunately, the check could not find a valid authentication method. You can generate authentication tokens via the “request authentication” option. Please keep in mind that DNS-based authentication may take a few hours before the entries are accessible.

And I don’t understand why in KonsoleH I cannot select the let’s encrypt certificate, it looks not enabled.
I send you a screen shot


#8

This all looks alien to me. You may have more luck contacting support of your hosting.

Unless you find a “push 1 button” solution in your panel, this method of obtaining certificates may prove inconvenient, since youʼll have to do this every 60–90 days.

You mention that you have root shell access, it may be more worthwhile to use a command line client.