Domain still shows not secure


I got a domain from Google and am with hosting site, SiteGround (SG). Got SSL for this domain with Let’s Encrypt and had HTTPS enforced. But after 48 hours of propagation, site’s still show not secure. Created/deleted/recreated site on SG, again, not secure. On Chrome, error code shown is NET::ERR_CERT_COMMON_NAME_INVALID. I had given up in seeing my domain still being not secure across ALL major browsers: Chrome, IE, FireFox, Safari, Android, may it also be over wi-fi or mobile data. All resources have been exhausted in an attempt to resolve this issue, including troubleshooting steps (install/reinstall, cleared cache, purged, flushed, reset, reboot, you name it), but to no avail. It’s frustrating as I’ve been trying for weeks already hoping to see this domain to be up and running and ready to be worked on with WordPress (WP).

My domain is:

I ran this command:

It produced this output: domain still shows not secure across ALL major browsers (Chrome, IE, FireFox), even across mobile and tablet access over wi-fi and mobile data

My web server is (include version): nginx

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: siteground

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): SiteGround’s own Site Tool

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @maria772007

there is no error visible -

Is it the correct domain name? is the host name, Google name servers used.

There are new certificates

Issuer not before not after Domain names LE-Duplicate next LE
Let's Encrypt Authority X3 2019-08-29 2019-11-27, - 2 entries duplicate nr. 3
Let's Encrypt Authority X3 2019-08-28 2019-11-26, - 2 entries duplicate nr. 2
Let's Encrypt Authority X3 2019-08-27 2019-11-25, - 2 entries duplicate nr. 1
Let's Encrypt Authority X3 2019-08-27 2019-11-25 *, - 2 entries duplicate nr. 1

one is used:
expires in 89 days, - 2 entries

all connections are secure, Grade B is very good. www + non www works, correct redirects.

And there are no mixed content warnings.

Last: Your non-www mail servers have the correct certificate, all is green.

Perhaps share a screenshot with the problem. Or it's only a caching problem.

Hi, Juergen,

Thanks for the response. Exactly! Even over shows all green for this domain, but I’m so frustrated to see that this domain shows otherwise. Any way Lets Encrypt can get this domain working in an acceptable condition for all browsers to accept as secure?

Thank you.

Please share a screenshot with the problem. Checked with FF + Chrome, no problem.

What says “Advanced”?

This server could not prove that it is ; its security certificate is from * . This may be caused by a misconfiguration or an attacker intercepting your connection.

SiteGround uses Let’s Encrypt.

Clear your cache.

Or do you have an old hosts entry?

What’s the ip you see?

Must be

PS: The mail server of the www version - - and the ip address have the

CN=*, OU=Domain Control Validated
	2	CN=AlphaSSL CA - SHA256 - G2, O=GlobalSign nv-sa, C=BE

certificate. But not your non-www domain.

Like I mentioned earlier, cleared cache and used other troubleshooting steps, but none worked out.

Yes, it’s

I wonder, though, if or how the site is being intercepted in-spite of having security installed. We saw that all is green and good for this domain.

This is getting frustrating as I couldn’t get this domain to use. :frowning: I’m hoping to get this security issue fixed.

Must be a local problem.

Same checked with SSLLabs - - no problem, Grade A.

Thank you, @JuergenAuer. Maybe so.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.