Domain Key does not match domain certificate


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: thediscourseng.com

I ran this command: Certificate renewal from zerossl

It produced this output: domain certificate.

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is arvixe:

I can login to a root shell on my machine (yes or no, or I don’t know): i dont know how to

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

I installed (copied and pasted) the renewed certificate on my site but i get a notice that the certificate does not match the domain key. please how can i get a domain key for the renewed certificate


#2

Hi,

I think the key is either the previous key or a new key generated by the client (browser)

Anyway, there is no way we can help you recover / find the key from our side.

You can either reissue the certificate (renew using a new key) or check if you recorded (received) the key before (if certificate key reused)

Thank you


#3

i was not issued a new key on renewal, so its the old key that doesn’t match


#4

Okay.

Can you tell me if you are using the client version of zerossl or web version?

Thank you


#5

i guess web version because i renewed from their website


#6

Okay.

Another question:

Do you use csr or just entered domain name, validate and get a text field of file and keys?

Thank you


#7

i used my LE key and csr


#8

If this is the case, (and suppose you use the csr generated from cPanel server)

Can you try to just fill in the certificate and click on “auto fill by certificate”? (The button should look blue, appear next to the certificate field on cPanel “install ssl” scene)

Thank you


#9

thats the LE key issued to me before


#10

let me try it, thanks.


#11

i did what you suggested but still got the same error messagw ‘the key does not match the certificate’.


#12

Then,

Can you try to issue another certificate? (Use a new generated csr from cPanel , with your LE account key)

Thank you


#13

thanks, i will try it


#14

your idea of generating a new csr worked. thanks


#15

Glad it worked.:slight_smile:

Just for reference: (CSR was used incorrectly. Might used the old csr…and not having the key…)


#16

i think I mixed things up then.


#17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.