Domain hosted in Google doesn't connect with Odoo without "www" prefix

Since a month I change my web page from wordpress in bluehost completely to Odoo website service included in the price of my ERP (Enterprise Resource Planning Software) but it was a nigthmare because if I try to enter directly from an ip that is "asigned" to my website ( shows me a page from Odoo that's says Oops, does't exist. But if I enter from it can enter normally.

When I try to enter with my domain from a browser this the message:


Reason: Invalid name of certificate. Either the name is not on the allowed list, or was explicitly excluded. View certificate

My domain is:

I ran this command: None for now

It produced this output: is redirected to also redirected to

My web server is (include version): Inside (

The operating system my web server runs on is (include version): I'm not secure, maybe in apache

My hosting provider, if applicable, is: I use Google Cloud DNS

I can login to a root shell on my machine (yes or no, or I don't know): just in Google Cloud DNS

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Not available

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Not aplicable doesn't know about your site: register your domain in their control panel



Sorry for don´t include the information.

All the process of a register a own domain is already did it. I followe the process in this part:

" Map your domain name with your Odoo database


Open your database manager, click on the settings button next to your database, on Domain names, and then on Use my own domain at the bottom of the right column.

Type the domain name you want to add to this database, then click on Verify to check if the CNAME record is correctly configured. Once done, click on I confirm, it’s done.

""""Verification of the CNAME records of a domain name before mapping it with a database


Make sure to add a CNAME record to your domain name’s DNS before mapping your domain name with your Odoo database.

Failing to do so may impede the validation of the SSL certificate and would result in a certificate name mismatch error. This is often displayed by web browsers as a warning such as “Your connection is not private”.

If this is the case and you have added the domain name to your database’s settings less than five days ago, wait 24 hours as the validation may still happen. Otherwise, please submit a support ticket including screenshots of your CNAME records."""""

But I made the the redirection CNAME from to a also did from to a but the certificate is not working well

The odoo docs say to use the CNAME to point to the odoo database

I have no experience with odoo but only your www domain has a CNAME and it points to your root domain name.

This really sounds like a question better directed to odoo support or their forum


Hi, thanks for you time,

They just says that, refer to this help page and do nothing, that's why I'm trying to do something about it because all my groups of ads in Google ads are blocked.

1 Like

add non www version into their dB as well. they will give default cert for any domain hit they don't know


Did you enter both names in Oodo?

Only "www" is secure:
SSL Server Test: (Powered by Qualys SSL Labs)
SSL Server Test: (Powered by Qualys SSL Labs)


You know you cannot put a CNAME in this zone, right?

According to their (Odoo) documentation you should set a redirect by yourself. This is bullshit, afaik.


Hi, thanks for the response.

Yes, I put a just domain name as my web page, also made a CNAME in google cloud from redirecting to a, and yes, as you said, only www is secure, but how can I put this security in just the naked domain to ACME or letsencrypt can accept the connection, but Odoo says that it is the problem.

DNS does not allow CNAME at the root domain level. It is not ACME or Let's Encrypt that is just how DNS works.

Maybe you need to change the IP address in the A record for to point directly to the IP for ? I am just guessing

It is very strange that Odoo cannot explain how this should work


Odoo is not providing you with good answers/suggestions.
If they can do "naked" domains, then they need to explain to you "how".
Just tell you that they can't.
[NOT blame unrelated things, nor ask you to do things that are not possible]


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.