Domain.com www.domain.com does not exist or is not a directory

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=mopixie.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: mopixie.com

I ran this command: ./certbot-auto

It produced this output: Action ‘graceful’ failed.
The Apache error log may have more information.
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ’
ServerName’ directive globally to suppress this message
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
Unable to restart apache using [‘apache2ctl’, ‘graceful’]
Encountered exception during recovery:
Traceback (most recent call last):
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/_internal/error_handler.py”, line 125,
in _call_registered
self.funcs-1
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/_internal/auth_handler.py”, line 243, i
n _cleanup_challenges
self.auth.cleanup(achalls)
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_apache/_internal/configurator.py”, line
2540, in cleanup
self.restart()
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_apache/_internal/configurator.py”, line
2410, in restart
self._reload()
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_apache/_internal/configurator.py”, line
2437, in _reload
raise errors.MisconfigurationError(error)
MisconfigurationError: Error while running apache2ctl graceful.
httpd not running, trying to start
Action ‘graceful’ failed.
The Apache error log may have more information.
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ’
ServerName’ directive globally to suppress this message
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
Error while running apache2ctl graceful.
httpd not running, trying to start
Action ‘graceful’ failed.
The Apache error log may have more information.
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.0.1. Set the ’
ServerName’ directive globally to suppress this message
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
root@wordpress-multisite-1-vm:~#

My web server is (include version): Google Cloud

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Google Cloud

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 1.4.0

There seems to be a problem with your Apache config.
What does this return?:
sudo ./apachectl -S

Also, you have a very “custom” redirection which will break LE authentication requests.
[unless you take proper precaution - but you haven’t yet]

curl -Iki http://mopixie.com/
HTTP/1.1 302 Found
Date: Sun, 10 May 2020 19:29:31 GMT
Server: Apache
X-Powered-By: PHP/7.3.17
X-Frame-Options: SAMEORIGIN
Location: http://34.86.128.151.xip.io/wp-signup.php?new=mopixie.com
Content-Type: text/html; charset=UTF-8

curl -Iki http://mopixie.com/.well-known/acme-challenge/test-file
HTTP/1.1 302 Found
Date: Sun, 10 May 2020 19:36:54 GMT
Server: Apache
X-Powered-By: PHP/7.3.17
X-Frame-Options: SAMEORIGIN
Location: http://34.86.128.151.xip.io/wp-signup.php?new=mopixie.com
Content-Type: text/html; charset=UTF-8

When I enter
sudo ./apachectl -S
it returns,
sudo: ./apachectl: command not found

Yes, I am also having this issue to be resolved. I need to point External Ip address to Domain.com.

I am using Google Cloud Bitnami Multisite Wordpress setup.

Here’s my external ip address: 34.86.128.151

Here’s my domain: mopixie.com

When I open it, by default it re-directs to http://34.86.128.151.xip.io/

I also added external ip address to mopixie.com - DNS - A - record.

But, When I open http://mopixie.com, it is redirecting to http://34.86.128.151.xip.io/wp-signup.php?new=mopixie.com

But it supposed remain as http://mopixie.com.
Please suggest the solution.

You should not be using certbot-auto with Bitnami.
See: Not able to run apache after certbot

1 Like

Thanks rg305 for guiding me right direction, All issues resolved with single command

sudo /opt/bitnami/bncert-tool
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.