DNS problem: SERVFAIL looking up CAA for ga

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:


I ran this command:

sudo certbot --apache

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated)  (Enter 'c' to cancel): www.magnusbrzenk.ga
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.magnusbrzenk.ga
Enabled Apache rewrite module
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. www.magnusbrzenk.ga (http-01): urn:ietf:params:acme:error:dns :: DNS problem: SERVFAIL looking up CAA for ga

 - The following errors were reported by the server:

   Domain: www.magnusbrzenk.ga
   Type:   None
   Detail: DNS problem: SERVFAIL looking up CAA for ga

My web server is (include version):

Apache/2.4.29 (Ubuntu)

The operating system my web server runs on is (include version):

Ubuntu 18.04

My hosting provider, if applicable, is:

AWS Lightsail

I can login to a root shell on my machine (yes or no, or I don’t know):


I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

certbot 0.31.0


I figured I'd give AWS lightsail a trial, so I redirected a free domain I set up 
(magnusbrzenk.ga) from a preivous target to a new target on AWS lightsail. 
Certbot worked fine with this domain with the previous target, but now it keeps failing with
`DNS problem: SERVFAIL looking up CAA for ga`. Any ideas what this is all about? 

It looks like the registry operator for the ga TLD (Freenom?) is having some issues. I can reproduce your issue with a different domain of mine (acmedev.ga).

Until they fix their nameservers, there is one workaround available to you, and that’s to create your own CAA record:

magnusbrzenk.ga. 360 IN      CAA     0 issue "letsencrypt.org"

OK, thanks for the info. Doesn’t look like freenom will let me create CAA records. I’ll check back in a day or two.

OK, it’s working now :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.