DNS problem: query timed out looking up A for

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: frenchdo.red5.org (but I am seeing the same issue with several red5.org sub-domains that I have tried)

I ran this command: certbot-auto certonly --standalone --email jessica@infrared5.com --agree-tos -d frenchdo.red5.org

It produced this output:
earlier, i saw:
Detail: DNS problem: SERVFAIL looking up CAA for frenchdo.red5.org

  • the domain’s nameservers may be malfunctioning

on retry:
Domain: frenchdo.red5.org
Type: dns
Detail: DNS problem: SERVFAIL looking up A for frenchdo.red5.org -
the domain’s nameservers may be malfunctioning

and when I tried again:

Challenge failed for domain frenchdo.red5.org
http-01 challenge for frenchdo.red5.org
Cleaning up challenges
Some challenges have failed.


My web server is (include version): tomcat 8.49 (but it is currently stopped while trying to renew my cert)

The operating system my web server runs on is (include version): Ubuntu 16.04

My hosting provider, if applicable, is: seeing the same issues on AWS and Digital Ocean -hosted servers

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 1.2.0

I have asked my domain host if there are any issues with their nameservers, and they swear up and down that there are not. Nslookup works, and http access works as expected.

There have been problems between the DNS provider red5.org is using (Network Solutions/Web.com) and Let’s Encrypt recently. :slightly_frowning_face: At this point there doesn’t seem to be anything you can do about it.

1 Like

It’s also not happening very often: every dig trace or direct query works perfectly. However, when I ran a “Lets Debug”, it gave inconsistent results: one non-DNS related error which had a good DNS lookup and for the CAA check it had a DNS-related error looking up the A record: https://letsdebug.net/frenchdo.red5.org/105046 Also, unboundtest.com doesn’t report any error for the CAA record lookup: https://unboundtest.com/m/CAA/frenchdo.red5.org/XN7UTJNL

1 Like

Thank you! And boo :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.