DNS problem: NXDOMAIN looking up A

My domain is: vtp.audionlinestock.sg, www.vtp.audionlinestock.sg
I ran this command: sudo certbot --apache
It produced this output: DNS problem: NXDOMAIN looking up A
My web server is (include version): Apache/2.4.52 (Ubuntu)
The operating system my web server runs on is (include version): Ubuntu 22.04.1 LTS (GNU/Linux 5.15.0-43-generic x86_64)
My hosting provider, if applicable, is: https://vodien.com/
I can login to a root shell on my machine : Yes
The version of my client is : certbot 1.21.0

I try reach help to customer service of provider, but they said their system not support manual SSL.
Did i miss something? please help this..

Thanks..

1 Like

This Statement from my customer service..
img

I'm afraid your support does not have a clue they're talking about, sorry. While they may be correct in that manually installing SSL is disabled, this is NOT related to the error you've shown.

The error clearly dictates DNS errors with your domain. Please see:

https://dnsviz.net/d/www.audionlinestock.sg/dnssec/

and

https://dnsviz.net/d/vtp.audionlinestock.sg/dnssec/

Clearly some DNS servers are (sometimes) not allowing requests for your domain. Weirdly enough sometimes ns1.vodien.com at 2400:cb00:2049:1::a29f:180a responds with "REFUSED" while sometimes it responds with NOERR and an IP address?

In any case, I believe the current issue is with the DNS.

6 Likes

Can you advise on fixing this issue? please...

Should I change something on manage DNS, like (CNAME, A, AAAA record)?
On digitalocean, We did the same procedure, the certbot worked well, no issue..

Thanks

1 Like

The name server at ns1.vodien.com that @Osiris mentioned before is giving very inconsistent results for your domain.

This might be a result of a misconfiguration by whoever runs that name server, rather than anything that you did. Do you know who runs it?

4 Likes

Hello Schoen, I'm developer of my client.. we didn't touch anything about the name server at ns1.vodien.com

Thanks..

1 Like

Did you see that that name server is listed as authoritative for this domain name?

1 Like

Hello Schoen, like this one?

Yeah. Can you ask the people who run that name server about the inconsistent answers it's currently giving for your domain? Again, that might not be because of your configuration.

4 Likes

Can, Thanks @schoen for the advice..
Thanks @schoen for the details..

2 Likes