--dns-linode-credentials failing

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: fmp.com

I ran this command: /usr/bin/certbot certonly -n
--server https://acme-v02.api.letsencrypt.org/directory
--dns-linode-credentials /root/[redacted]
--dns-linode-propagation-seconds 1000
-d *.fmp.com

It produced this output:
certbot: error: unrecognized arguments: --dns-linode-credentials /root/[redacted] --dns-linode-propagation-seconds 1000

(fq path to Linode API credentials has been redacted)

My web server is (include version): Apache/2.4.18

The operating system my web server runs on is (include version): Ubuntu 16.04.7 LTS

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.21.0

I have been running the command (above) from a cron job to periodically automatically re-create a wildcard cert for my domain name, and for at least a year or so it has been running without a hitch. Recently, however, it seems that the --dns-linode-credentials and --dns-linode-propagation-seconds are no longer recognized by certbot. This has been scripted locally, and perhaps I'm no longer paying attention, but what has changed, and what do I need to do to get my script working again?

What's the output of:

certbot plugins
  • apache
    Description: Apache Web Server plugin
    Interfaces: Installer, Authenticator, Plugin
    Entry point: apache = certbot_apache._internal.entrypoint:ENTRYPOINT

  • nginx
    Description: Nginx Web Server plugin
    Interfaces: Installer, Authenticator, Plugin
    Entry point: nginx = certbot_nginx._internal.configurator:NginxConfigurator

  • standalone
    Description: Spin up a temporary webserver
    Interfaces: Authenticator, Plugin
    Entry point: standalone = certbot._internal.plugins.standalone:Authenticator

  • webroot
    Description: Place files in webroot directory
    Interfaces: Authenticator, Plugin
    Entry point: webroot = certbot._internal.plugins.webroot:Authenticator

The dns-linode plugin is no longer installed. Where can I get a compatible version?

It looks like you are probably using the Certbot snap, so installing it should be something like:

 sudo snap set certbot trust-plugin-with-root=ok
 sudo snap install certbot-dns-linode

Thank you!! I dug a little deeper and while waiting for your reply I located a reference to exactly these two commands, which I ran, and now certbot plugins shows me that the dns-linode plugin is installed. I'll give my script another shot!


Again, thanks! Installing the plugin and running the appropriate script got me the wildcard cert. I consider the problem solved.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.