Dns error - unable to fix

Hi, I need a hand, I blew up my site, I followed some guides in the network to activate SSL but the site is not reachable despite the certificate is still detected (chrome says that there are too many redirects).
I tried to run the installation with two different commands and in the second case I got an error concerning the dns (I think because you use cloudflare) how can I do to disable everything and go back to normal without the certificates? Thanks a lot in advance for the help

My domain is: mortadella.tk

My web server is (include version): apache2

The operating system my web server runs on is (include version): ubuntu 16.04

I can login to a root shell on my machine (yes or no, or I don’t know): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): latest version

Hi @WaspEma

you have a direct loop https -> https ( https://check-your-website.server-daten.de/?q=mortadella.tk ):

Domainname Http-Status redirect Sec. G
http://mortadella.tk/
104.27.170.62 301 https://mortadella.tk/ 0.070 A
http://mortadella.tk/
104.27.171.62 301 https://mortadella.tk/ 0.070 A
http://mortadella.tk/
2606:4700:30::681b:aa3e 301 https://mortadella.tk/ 0.074 A
http://mortadella.tk/
2606:4700:30::681b:ab3e 301 https://mortadella.tk/ 0.073 A
https://mortadella.tk/
104.27.170.62 301 https://mortadella.tk/ 0.263 L
https://mortadella.tk/
104.27.171.62 301 https://mortadella.tk/ 0.173 L
https://mortadella.tk/
2606:4700:30::681b:aa3e 301 https://mortadella.tk/ 0.166 L
https://mortadella.tk/
2606:4700:30::681b:ab3e 301 https://mortadella.tk/ 0.177 L

That’s not a DNS problem. Check the redirects of your webserver.

But you use Cloudflare, that makes it harder to fix the problem.

So first step: Remove Cloudflare, then recheck your domain, then fix the wrong redirect.

And you have two active certificates:

CertSpotter-Id Issuer not before not after Domain names LE-Duplicate next LE
924902291 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2019-05-22 02:41:21 2019-08-20 02:41:21 mortadella.tk
1 entries duplicate nr. 2
924817508 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2019-05-22 01:56:16 2019-08-20 01:56:16 mortadella.tk
1 entries duplicate nr. 1

So certificate creation has worked.

1 Like

thanks for the information, I will look for a solution, in case you didn’t find it a good method to bring everything back to normal, is there? would be the fastest solution. Thanks so much for your kind attention

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.