Dietpi certbot no certificate creation

Hello,
I am not able to create a certificate with dietpi certbot.
I get the following error message
SUB1 ] DietPi-LetsEncrypt > Running Certbot
[ OK ] DietPi-LetsEncrypt | Apache2 webserver detected
[ OK ] DietPi-LetsEncrypt | Desired setting in /etc/apache2/sites-available/000-default.conf was already set: ServerName halunke.dynv6.net
[ OK ] DietPi-LetsEncrypt | systemctl restart apache2
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for halunke.dynv6.net
Enabled Apache rewrite module
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. halunke.dynv6.net (http-01): urn:ietf:params:acme:error:dns :: No valid IP addresses found for halunke.dynv6.net

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: halunke.dynv6.net
    Type: None
    Detail: No valid IP addresses found for halunke.dynv6.net
    [FAILED] Certbot failed with error code (1), please check its terminal output. Aborting...
    [ SUB2 ] DietPi-Services > restart
    [ OK ] DietPi-Services | restart : nmbd
    [ OK ] DietPi-Services | restart : smbd
    [ OK ] DietPi-Services | restart : mariadb
    [ OK ] DietPi-Services | restart : php7.3-fpm
    [ OK ] DietPi-Services | restart : apache2
    [FAILED] DietPi-Services | restart : nginx
    [ OK ] DietPi-Services | restart : cron
    root@DietPi:~# dietpi-letsencrypt
    [ SUB1 ] DietPi-LetsEncrypt > Running Certbot
    [ OK ] DietPi-LetsEncrypt | Apache2 webserver detected
    [ OK ] DietPi-LetsEncrypt | Desired setting in /etc/apache2/sites-available/000-default.conf was already set: ServerName halunke.dynv6.net
    [ OK ] DietPi-LetsEncrypt | systemctl restart apache2
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Plugins selected: Authenticator apache, Installer apache
    Obtaining a new certificate
    Performing the following challenges:
    http-01 challenge for halunke.dynv6.net
    Enabled Apache rewrite module
    Waiting for verification...
    Cleaning up challenges
    Failed authorization procedure. halunke.dynv6.net (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://halunke.dynv6.net/.well-known/acme-challenge/rxmCPFT9rZYEwQYSnSRQqHidgNkglz5UdTaRBGTVkcY: Connection refused

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: halunke.dynv6.net
    Type: connection
    Detail: Fetching
    http://halunke.dynv6.net/.well-known/acme-challenge/rxmCPFT9rZYEwQYSnSRQqHidgNkglz5UdTaRBGTVkcY:
    Connection refused

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you're using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.
    [FAILED] Certbot failed with error code (1), please check its terminal output. Aborting...
    [ SUB2 ] DietPi-Services > restart
    [ OK ] DietPi-Services | restart : nmbd
    [ OK ] DietPi-Services | restart : smbd
    [ OK ] DietPi-Services | restart : mariadb
    [ OK ] DietPi-Services | restart : php7.3-fpm
    [ OK ] DietPi-Services | restart : apache2
    [FAILED] DietPi-Services | restart : nginx
    [ OK ] DietPi-Services | restart : cron

When I search on the internet for my ip it gives me the
176.96.152... is displayed. With this ip I can not get on the server.
In my router which is directly connected to the fiber network with PPPoE there is a WAN Ip with 10.64.32... in the router. With this I can get to the Apache server with my Dynv6 address.
When trying to create a certificate comes upper error message.
I have taken the Apache and not the light because here in the forum one had success with apache.
The DynDns settings and port shares are made on the router.
No idea what else I can do so that the certificate creation works. Maybe someone has a solution to what my error could be.

Translated with www.DeepL.com/Translator (free version)
Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:halunke.dynv6.net

I ran this command:

It produced this output:

My web server is (include version):apache

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:dynv6.com

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Do you mean 100.64.x.x, by any chance?

It sounds like you might be behind CGNAT, which would prevent you from being able to host any IPv4 services on the internet: https://en.wikipedia.org/wiki/Carrier-grade_NAT

Does your ISP give you any IPv6 addresses? You might be able to use that to get a certificate.

2 Likes

Hi @cannibale

it's possible to ping your domain name.

So the global ip configuration looks ok.

But it's not possible to load

http://halunke.dynv6.net/

there is a connection refused.

May be a wrong port forwarding extern 80 -> intern 80 or something else (a not running webserver or another program that blocks port 80).

1 Like

yes funny. it always worked before. i got to the apache page. Now i can't get to it either. i think i tried too much.
In the firewall at unifi controller are all rules port forwarding to accepted .
I have also already taken another dyndns provider no-ip. I had the same problem.
Because of the port 80. can it be: I have another second pi where pihole runs, and the internal devices go through this dns. But that has nothing to do with it, right? And letsentcrypt is not blogged
Eine Frage noch: Jürgen Auer hört sich Deutsch an:) kann ich meine anfragen auf deutsch senden?
now it should go with the dyndns.

1 Like

Jürgen is definitely German but he is likely to answer your questions in English based on his previous policy, z.B. his remark "ohne Englisch geht im Computerbereich nichts"!

All languages are allowed on this forum. However you may frequently receive a reply in English if the person helping you doesn't speak your language well, or simply prefers to answer in English. The forum administrators (of whom I used to be one but am no longer one) have encouraged people to feel comfortable posting their questions in their native languages.

2 Likes

real, right? I didn't know that nothing works except english. This was just an incidental question to Mr. Auer. Please do not teach me about world issues. I would prefer a hint about my problem with letsencrypt. No matter if english or german

My own thought is that if you have a dynamic DNS client application, it might be telling the DNS provider your LAN address rather than your public IP address.

At least, the current problem reported by the Let's Encrypt CA is about the fact that your IP address in DNS is in the 10 network, which is private IP address space typically used on a LAN. It's possible that you have a public address with port forwarding working correctly, but Let's Encrypt doesn't even know where to find that because the IP address reported via DNS is a private LAN address on the 10 network instead.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.