Deleted older GIT letsencrypt now Apache will not start repost


#1

I posted this a little more than a month ago but have not been able to resolve. If anyone can give me some help as to how I can get apache going to make my domains available to letsencrypt so I can replace the deleted certs I’d be very grateful.

"Last months post"
Early in the year I setup letsencrypt from GIT. It never updated automatically. At the time there was no apt package for Debian Jessie but since there is now I decided to remove letsencrypt and reinstall from apt-get. I followed the instructions from the forum as follows:

"Warning: This will delete ALL certificates (including private keys), account keys, renewal configuration and log files. Don’t run this unless you have a good reason to!
You might also be interested in the config_changes or rollback subcommands for the apache plugin, allowing you to view or revert changes made to your apache configuration.

Off the top of my head, this should remove any traces:

rm -rf /path/to/your/git/clone/directory
rm -rf ~/.local/share/letsencrypt
rm -rf /etc/letsencrypt
rm -rf /var/log/letsencrypt
rm -rf /var/lib/letsencrypt
(Let me know if I missed anything!)"

After removing I installed letsencrypt from apt-get and now apache will not start. I get the following error when I try to start apache:

root@LinuxServer:/etc/letsencrypt/live# service apache2 start
Job for apache2.service failed. See ‘systemctl status apache2.service’ and ‘journalctl -xn’ for details.
root@LinuxServer:/etc/letsencrypt/live# journalctl -xn
– Logs begin at Fri 2016-10-21 18:00:36 EDT, end at Wed 2016-11-09 19:18:37 EST. –
Nov 09 19:18:37 LinuxServer systemd[1]: Starting LSB: Apache2 web server…
– Subject: Unit apache2.service has begun with start-up
– Defined-By: systemd
– Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

– Unit apache2.service has begun starting up.
Nov 09 19:18:37 LinuxServer apache2[25571]: Starting web server: apache2 failed!
Nov 09 19:18:37 LinuxServer apache2[25571]: The apache2 configtest failed. … (warning).
Nov 09 19:18:37 LinuxServer apache2[25571]: Output of config test was:
Nov 09 19:18:37 LinuxServer apache2[25571]: apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/a
Nov 09 19:18:37 LinuxServer apache2[25571]: Action ‘configtest’ failed.
Nov 09 19:18:37 LinuxServer apache2[25571]: The Apache error log may have more information.
Nov 09 19:18:37 LinuxServer systemd[1]: apache2.service: control process exited, code=exited status=1
Nov 09 19:18:37 LinuxServer systemd[1]: Failed to start LSB: Apache2 web server.
– Subject: Unit apache2.service has failed
– Defined-By: systemd
– Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

– Unit apache2.service has failed.

– The result is failed.
Nov 09 19:18:37 LinuxServer systemd[1]: Unit apache2.service entered failed state.

I am not an expert with using Linux so any concise help would be greatly appreciated.

Thanks…
Dave
"End of last months post"

Please fill out the fields below so we can help you better.

My domain is: davidovad.com

I ran this command: certonly --webroot -w /var/www/davidovad -d davidovad.com -d vpn.davidovad.com -d news.davidovad.com -d owncloud.davidovad.com -d linuxserver.davidovad.com -d server.davidovad.com -d wiki.davidovad.com -d blog.davidovad.com

It produced this output: Failed authorization procedure. blog.davidovad.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to blog.davidovad.com, server.davidovad.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to server.davidovad.com, wiki.davidovad.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to wiki.davidovad.com, davidovad.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to davidovad.com, linuxserver.davidovad.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to linuxserver.davidovad.com, owncloud.davidovad.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to owncloud.davidovad.com, news.davidovad.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to news.davidovad.com, vpn.davidovad.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to vpn.davidovad.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: blog.davidovad.com
    Type: connection
    Detail: Could not connect to blog.davidovad.com

    Domain: server.davidovad.com
    Type: connection
    Detail: Could not connect to server.davidovad.com

    Domain: wiki.davidovad.com
    Type: connection
    Detail: Could not connect to wiki.davidovad.com

    Domain: davidovad.com
    Type: connection
    Detail: Could not connect to davidovad.com

    Domain: linuxserver.davidovad.com
    Type: connection
    Detail: Could not connect to linuxserver.davidovad.com

    Domain: owncloud.davidovad.com
    Type: connection
    Detail: Could not connect to owncloud.davidovad.com

    Domain: news.davidovad.com
    Type: connection
    Detail: Could not connect to news.davidovad.com

    Domain: vpn.davidovad.com
    Type: connection
    Detail: Could not connect to vpn.davidovad.com

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.
    root@LinuxServer:/home/dovad# nano /etc/apache2/sites-available/default-ssl.conf
    root@LinuxServer:/home/dovad# apt-gat update^C
    root@LinuxServer:/home/dovad# service apache2 restart
    Job for apache2.service failed. See ‘systemctl status apache2.service’ and ‘journalctl -xn’ for details.
    root@LinuxServer:/home/dovad# nano /etc/apache2/sites-available/default-ssl.conf
    root@LinuxServer:/home/dovad# service apache2 restart
    Job for apache2.service failed. See ‘systemctl status apache2.service’ and ‘journalctl -xn’ for details.
    root@LinuxServer:/home/dovad# nano /etc/apache2/sites-available/default-ssl.conf
    root@LinuxServer:/home/dovad# apache2-ssl-certificate
    bash: apache2-ssl-certificate: command not found

My operating system is (include version): Debian 8

My web server is (include version): Apache/2.4.10 (Debian)

My hosting provider, if applicable, is: hosted at home

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Are there any clues at the locations it states …

Syntax error on line 140 of /etc/apache2/apache2.conf:
Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load:

What is near those lines


#3

I also wonder if you could do

grep -r /etc/letsencrypt /etc/apache2

to see if there are any references to the deleted certificates still present in your config files (which would definitely make Apache have trouble starting, but I wouldn’t expect it to produce exactly the error messages that you’re seeing).


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.