[Debian 9 / Certbot 0.28.0] Update your client software to continue using Let's Encrypt

Hello.
I received the email that tells me to update my certbot because of the ACMEv1 protocol.

But, which version i need? And how can i upgrade it in debian 9? Because i already updated to the lates available version (0.28) but i’m still receiving this email.

Before the email i had a version like 0.19, now i’m on 0.28.0 and is the latest version available on debian 9, there are no instructions for upgrading in the official lets encrypt website.

Thank you in advance.

You need to upgrade ACME protocol version, not certbot version.

Thank you for the reply.
It is really strange because i’ve seen that i may need to update my config files of any website.
But i’ve seen the config file of the website that letsencrypt told in the email, and it has already the acmev2 in the server section.

Emails might arrive late; if you are sure you are using ACMEv2, it’s fine.

Well, i see that i have the acmev2 settings in my config file, but how can i be sure that is actually using it? Is there any command to check?

Thank you in advance.

you need to check the individual configs in /etc/letsencrypt/renewal too.

I checked only those file and they have the correct server settings.
Is there anything else do i need to check?
Thank you.

you may have a global configuration file in some directory: https://certbot.eff.org/docs/using.html#configuration-file

look in your logs /var/log/letsencrypt