Curl error: 35 (SSL_CONNECT_ERROR)


#1

My domain is: https://coatbridgeandthegreatwar.com

I ran this command: https://coatbridgeandthegreatwar.com/memorial.php?man_id=2
In Facebook debugger

It produced this output:

  • Inferred Property - The ‘og:image’ property should be explicitly provided, even if a value can be inferred from other tags.

  • Missing Properties - The following required properties are missing: og:url, og:type, og:title, og:image, og:description, fb:app_id

  • Curl Error - Curl error: 35 (SSL_CONNECT_ERROR)

My web server is (include version): nginx 1.13.8

The operating system my web server runs on is (include version): Centos 7.5.1804

My hosting provider, if applicable, is: 1 & 1 cloud server.

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Onyx

Hi, I have a facebook share icon on some of my pages and have included the meta tags that facebook requires but getting the curl error above and facebook only shows the link with the domain name and none of the meta data.

SSLlabs shows the cert as being grade A and don’t have any problems accessing the site securely. I’ve tried stack overflow but nothing on there that can fix the issue and tried a facebook developers group but received no answer to my query.

Thanking you in anticipation!


#2

The domain resolves to both IPv4 and IPv6 addresses.
The IPv4 address seems to work correctly (and served by nginx).
The IPv6 address is the one with the problem (and served by Apache).


#3

Hi @scanmaster1970

checking with SSLLabs:

Failed to communicate with the secure server

So SSLLabs can’t connect the site.


#4

So I have an IPV6 problem then? Thanks for the answers guys!


#5

The DNS was pointing to the wrong IPV6 domain. Fixed now. Thanks again!