Creation of certificate fails with certbot and certbot-auto

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: gpsdevb.hotsplots.de

I ran this command:
certbot --nginx
or just
certbot
or
certbot-auto
It produced this output:
root@mydevb:~# /opt/certbot-auto -d gpsdevb.hotsplots.de
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
An unexpected error occurred:
SSLError: HTTPSConnectionPool(host=‘acme-v02.api.letsencrypt.org’, port=443): Max retries exceeded with url: /directory (Caused by SSLError(SSLError(“bad handshake: SysCallError(104, ‘ECONNRESET’)”,),))
Please see the logfiles in /var/log/letsencrypt for more details.
root@mydevb:~# ping acme-v02.api.letsencrypt.org
PING ca80a1adb12a4fbdac5ffcbc944e9a61.pacloudflare.com (172.65.32.248) 56(84) bytes of data.
64 bytes from 172.65.32.248 (172.65.32.248): icmp_seq=1 ttl=61 time=0.815 ms
64 bytes from 172.65.32.248 (172.65.32.248): icmp_seq=1 ttl=61 time=12.7 ms (DUP!)
64 bytes from 172.65.32.248 (172.65.32.248): icmp_seq=2 ttl=61 time=0.834 ms
64 bytes from 172.65.32.248 (172.65.32.248): icmp_seq=2 ttl=61 time=12.8 ms (DUP!)
^C

My web server is (include version):

nginx

The operating system my web server runs on is (include version):
debian10
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 1.2.0

1 Like

Hi @marcel.blenkers,

It looks like your server’s outbound Internet access is strange somehow. Do you have a firewall or proxy that somehow limits outgoing connections from this server?

1 Like

Is this happening all the time, or just occasionally? What if you try again?

1 Like

Hi @schoen,

i disabled the iptables-service but still got this issue.

But i found something strange at the datacenter. Some maschines got strange replies. i already informed the provider.
Lets wait what he will find out.

Greetings

Marcel

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.