Certbot bad handshake issue

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
certbot --nginx

It produced this output:
requests.exceptions.SSLError: HTTPSConnectionPool(host='acme-v02.api.letsencrypt.org', port=443): Max retries exceeded with url: /directory (Caused by SSLError(SSLError("bad handshake: SysCallError(-1, 'Unexpected EOF')")))

My web server is (include version):
Nginx 1.18.0

The operating system my web server runs on is (include version):
Ubuntu 20.10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
I think so? I have root access... new to Linux machines and vocabulary

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.7.0

I've tried a couple things to get this working, I've browsed this forum for a bit to no prevail. I've set this up a couple months prior and had no issues, so I'm not sure if this in a me issue or not, but any help would be great!


Hello! We had blocked your IP address temporarily due to its participation in a DDoS attack against us. I've unblocked it for you, and you should now be able to request certificates.

If your system's IP address just recently changed to its current one, then the problem was with the previous holder of that IP.

Otherwise, please check your system carefully: the system, or a site on it, may have been compromised and used to attack others, including us.


My old IP did get flagged with a DDoS attack, but I have moved to a new VPS and it's locked down as about as tight as I can get it. Thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.