cPanel AutoSSL Error On WHM

Hello Everyone,
Face some error on AutoSSL (WHM)
Show some error

API failure: Net::ACME2::x::HTTP::Network: The system failed to send an HTTP “GET” request to “” because of an error: SSL connection failed for SSL connect attempt failed error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed ...propagated at /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/Net/ACME2/, line 225
any way to fix that :slight_smile:


Hi @Robiul_Islam,

This suggests that the network your server is on isn't able to connect to the Let's Encrypt service.

If you have access to a command line on this server, you could try running a command like

curl -v

to find out more about what the problem might be. One example would be that the network where your server is hosted has a firewall restricting outbound network connections, or that it has broken DNS servers.


Hello, @schoen
this is ouput form server
can you check it :slight_smile:

[root@de ~]# curl -v

  • About to connect() to port 443 (#0)
  • Trying
  • Connected to ( port 443 (#0)
  • Initializing NSS with certpath: sql:/etc/pki/nssdb
  • CAfile: /etc/pki/tls/certs/ca-bundle.crt
    CApath: none
  • SSL connection using TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
  • Server certificate:
  •   subject:
  •   start date: Feb 03 10:12:43 2021 GMT
  •   expire date: May 04 10:12:43 2021 GMT
  •   common name:
  •   issuer: CN=R3,O=Let's Encrypt,C=US

GET /directory HTTP/1.1
User-Agent: curl/7.29.0
Accept: /

< HTTP/1.1 200 OK
< Server: nginx
< Date: Wed, 17 Feb 2021 00:26:35 GMT
< Content-Type: application/json
< Content-Length: 658
< Connection: keep-alive
< Cache-Control: public, max-age=0, no-cache
< X-Frame-Options: DENY
< Strict-Transport-Security: max-age=604800
"VAxRfrffrf": "Adding random entries to the directory",
"keyChange": "",
"meta": {
"caaIdentities": [
"termsOfService": "",
"website": ""
"newAccount": "",
"newNonce": "",
"newOrder": "",
"revokeCert": ""


After update cPanel


its working Again fine.
Thanks for replay :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.