Could not issue certificate using certbot, authorization error

My domain is:

I ran this command:

sudo /usr/bin/certbot --nginx -d

It produced this output:

Failed authorization procedure. (http-01): urn:ietf:params:acme:error:connection :: 
The server could not connect to the client to verify the domain :: Fetching Timeout during connect (likely firewall problem)

My web server is (include version):


The operating system my web server runs on is (include version):

Ubuntu 20.0.4

My hosting provider, if applicable, is: azure cloud

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

certbot 0.31.0

It's probably a firewall issue, or nginx isn't starting.

We can't run any diagnostics if you don't tell us the actual domain name.

1 Like

No, it isn't. As the question template says, we need your real domain name in order to help you.

This error message seems pretty clear: Let's Encrypt's validation servers were unable to connect to your server. Fix whatever's in the way of that connection and try again.


i have updated the question with the actual domain,

Regarding firewall, firewall is completely inactive, even though when i activate it, issue could not be resolved

sudo ufw status
Status: inactive
sudo ufw enable

Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
Firewall is active and enabled on system startup
 sudo ufw status
\Status: active

To                         Action      From
--                         ------      ----
80                         ALLOW       Anywhere                  
443                        ALLOW       Anywhere                  
8069                       ALLOW       Anywhere                  
80 (v6)                    ALLOW       Anywhere (v6)             
443 (v6)                   ALLOW       Anywhere (v6)             
8069 (v6)                  ALLOW       Anywhere (v6)

Either something's blocking that connection, or nginx isn't running. One way or the other, HTTP connections are failing. See:

...and I'm seeing the same issue when I try to connect from my browser.


I see 443 as closed, no 80, no 8069. Just 22 answers.

Check if there's another firewall, in the azure console probably.


i have recalled that security group in amazon cloud after 1 day of investigation, port 80 was not opened in cloud firewall

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.