Common Name Invalid

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: I simply tried to login to the site /admin

It produced this output: COMMON_NAME_INVALID

My web server is (include version):

The operating system my web server runs on is (include version): Unkn

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot)

Can someone PLEASE fix the error that Let's Encrypt caused by using the wrong Common Name???

FRUSTRATED in the sky - Soni

Let's Encrypt didn't cause any error, as they didn't configure this web site. Whoever configured your site did, by configuring it to use a cert that doesn't include the site's domain name. If you're the admin for the site, you'll need to fix that. If you aren't the site admin, you'll need to ask that person to fix it.


Your site is clearly hosted by so that's who you need to talk to. GoDaddy is your DNS host/Domain registrar, but not your actual website webserver host.

Siteground have given your website a default certificate named after the server it's running on but configuring a certificate specific to your domain is normally up to you. It looks like they have instructions here: How to Add an SSL to Your Site - SiteGround Tutorials


It seems that your site redirects HTTP to HTTPS but you haven't provided a certificate for it - so the web server replies with the default domain / first secure vhost.

Also, is not a web server:

[I suppose that says it all]


This link is great and I read thru it and it has a lot of info BUT the problem is that I cannot get into the website admin to do any of it. I will try to to get a hold of - thanks


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.