Common I guess: Can't reach my website

My domain is: surfgate.be

I ran this command:Powershell

It produced this output: Fatal: Check of /.well-known/acme-challenge/random-filename has a http status 500 - 599, Server Error. Creating a Letsencrypt certificate via http-01 challenge can’t work.

My web server is (include version): IIS 10.0

The operating system my web server runs on is (include version): Win 16 Server

My hosting provider, if applicable, is: My owb - Static IP

I can login to a root shell on my machine (yes or no, or I don’t know): N/A

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Yes
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Latest

I tried to adapt my code but I can’t reach my site from any device.
SSLlabs and other sites like chech-my-site find it but I get a this above error.
Webmail still onlinne, but not the site (what left over it).

I found some docs that applies to redirection.

Hi @Attacus

that’s

not the output of your powershell, that’s the output of your online check https://check-your-website.server-daten.de/?q=surfgate.be - 2,5 hours old.

And the result is curious: http + https works, only

http://surfgate.be/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de

has that error.

That’s an internal problem of your IIS.10 - webserver you have to fix.

I will check the webconfig. I only use TLS 1.2. It worked before… Keep you guys uodated.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.