Chrome/Webmin connection refused

Problem is trying to use Webmin on just updated to Mageia 6.
httpd.conf contains no virtual hosts.
00_default_ssl_vhost.conf contains:

default SSL virtual host, used for all HTTPS requests that do not

match a ServerName or ServerAlias in any block.

# general configuration ServerAdmin root@localhost ServerName localhost
# SSL configuration
SSLEngine on
SSLCertificateFile "/etc/letsencrypt/live/gemmill.name/fullchain.pem"
SSLCertificateKeyFile "/etc/letsencrypt/live/gemmill.name/privkey.pem"
CustomLog logs/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
Certificate was recently updated

My domain is: gemmill.name, share.gemmill.name

I ran this command: https://localhost:10000, https://gemmill.name:10000 and other variations

It produced this output:This site can’t be reached
gemmill.name refused to connect.

My web server is (include version): Chrome 63.0.3239.132

The operating system my web server runs on is (include version):Mageia 6 x86_64

My hosting provider, if applicable, is: 1and1.co.uk

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

It looks fine for me now in Chromium—did you resolve the problem somehow?

No, still not working. I tried https://192.168.1.9
Got red triangle plus
Your connection is not private
Attackers might be trying to steal your information from 192.168.1.9 (for example, passwords, messages or credit cards). Learn more
NET::ERR_CERT_COMMON_NAME_INVALID
However, certificate details make no mention of invalidity. Seems Chrome doesn’t like your CN: Let’s Encrypt Authority X3!!
Graeme

It will give an error using “192.168.1.9” because that doesn’t match “gemmill.name” - hence the error of “NAME_INVALID”.

Does it work correctly if you use the domain name ( it does for me)

Yes, https://gemmill.name makes a secure connection. However, still can’t get access to Webmin on port 10000. There must be a more significant problem.
Thanks so far.
Graeme

Have you added the certificate to webmin and port 10000 ?

Is the server listening on port 10000 ?

Are there any firewalls blocking access to port 10000 ?

Must have been an installation problem - I removed Webmin and re-installed it. I can connect insecurely at localhost:10000, but it doesn’t like the https:// connection. Still, I have access…
Thanks
Graeme

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.