Check if IP is blocked HTTPSConnectionPool(host=‘’, port=443):

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot certonly -a dns-multi --dns-multi-credentials=/etc/letsencrypt/dns-multi.ini -d "" --dry-run

It produced this output: An unexpected error occurred:
requests.exceptions.SSLError: HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /directory (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: certificate is not yet valid (_ssl.c:1131)')))

My web server is (include version): Apache/2.4.54 (FEDORA LINUX)

The operating system my web server runs on is (include version): FEDORA LINUX Server 37

My hosting provider, if applicable, is: DYNU (using ddns)

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Yes (Fedora Server Control Panel)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.32.2

Note: I think my ISP Public IP ( is blocked based on reading this forum post. (Check if IP is blocked HTTPSConnectionPool(host='', port=443): - #2 by ezekiel)

But this is a dynamic IP address, so if you unblock it won't I experience issues in the future, or is it just when the certificate is being issued?

Hi @1eragonrider, and welcome to the LE community forum :slight_smile:

That's not a blocked IP response.
Is the time, and time zone, accurate on your system?


I agree with Rudy. The cert is valid since 29-12-2022. So something seems to be terribly wrong with the date of your host.


This was the solution the date was 2022-12-22 and time was all wrong. I fixed it and was able to successfully receive the certificate. Now I have to find out how to install it to my apache nextcloud server...


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.