Changed the domain - Revoked and tried to renew certificate - Error message

Hello, I had to do a domain name change from to .com
When I tried to reinstall a SSL certificate to the new domain name, I encountered many issues:

My domain is:

I ran this command:

sudo certbot certificates
sudo certbot revoke --certname (ex domain name)

Then I did:

sudo certbot --apache

It produced this output:
The apache plugin is not working; there may be problems with your existing configuration.
The error was: MisconfigurationError("Error while running apache2ctl configtest.\nAction 'configtest' failed.\nThe Apache error log may have more information.\n\nAH00526: Syntax error on line 17 of /etc/apache2/sites-enabled/lamp-server-le-ssl.conf:\nSSLCertificateFile: file '/etc/letsencrypt/live/bonusmeup.com/fullchain.pem' does not exist or is empty\n")

My web server is (include version): Apache Debian 11

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Google cloud

I can login to a root shell on my machine (yes or no, or I don't know): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.7.4

Hi @Roma, and welcome to the LE community forum :slight_smile:

What was the point of revoking that cert?

Could that be why you now get?:

3 Likes

The point was to install a certificate for the new domain name.
I am not a great expert so I thought It was the right way to do

Then you missed your point [mark].
Revoking has nothing to do with installing a cert, nor adding a new domain [to a new cert or an existing cert].

3 Likes

Do you know what I can do to fix the issue and install a new certificate for the domain Casivoo.com?

To overcome the current situation you will have to first get Apache to start.
For that you will have to do one of these:

  • remove the broken config file
    a2dissite /etc/apache2/sites-enabled/lamp-server-le-ssl.conf
    [then reenable it after you have replaced the missing cert]

  • provide that vhost config file a [temporary] cert for it to use [and get Apache to start]
    a. point the files to the snake-oil cert [found somewhere on your drive]
    b. point the files to any other valid cert [even if it doesn't cover the names in that vhost]
    [again, just to get Apache to start]

4 Likes

Thanks, but this goes way above my technical skills.

Could you indicate me how to:

  • Remove the broken config file

  • Point the file to other valid cert (there are no certs installed)

I gave you the command for that:

I can see what you mean by:

4 Likes

Thanks for the help but this is the message i receive:
romain@bonusme-up-vm:~$ a2dissite /etc/apache2/sites-enabled/lamp-server-le-ssl.conf
-bash: a2dissite: command not found
romain@bonusme-up-vm:~$

Please show:
sudo find / -name a2dis*

3 Likes

/usr/sbin/a2dismod
/usr/sbin/a2disconf
/usr/sbin/a2dissite
/usr/share/man/man8/a2dissite.8.gz
/usr/share/man/man8/a2disconf.8.gz
/usr/share/man/man8/a2dismod.8.gz
/usr/share/bash-completion/completions/a2dismod
/usr/share/bash-completion/completions/a2disconf
/usr/share/bash-completion/completions/a2dissite

It does exists.
hmm...
Try it with sudo:
sudo a2dissite /etc/apache2/sites-enabled/lamp-server-le-ssl.conf
If that fails to run, then also include the entire path in the command:
sudo /usr/sbin/a2dissite /etc/apache2/sites-enabled/lamp-server-le-ssl.conf

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.