Change www.domain.com to *.domain.com or domain.com

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://www.example.com
Edit* removed url to avoid bad trafic.
I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is: Amazonlightsail

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): I am using amazon lightsail console to manage my site.


My Question is different. The SSL Certificate generated has www before the domain. While I want it to be without www. So my domain is www.example.com. Certificate is generated for www.example.com. But for some reasons I need it to be example.com.
Kindly let me know what is the issue.

1 Like

You can specify all domain names which should be included into the certificate upon issuance. Since you did not mention how you created the certificate, this is all I can say.

1 Like

Nice Site and support is ready to chat! Looks like a port redirect is in place. might want to remove it and make sure that your root host (without the “www”) has a vhost configured… lets start with that.

I need my domain to be only example.com. Without www.

How to do that? Any tutorial link for the same?

OK… Do you have access to the configuration of the web server that is hosting Wordpress? There are resources that can help.

Yes I do have access to root.

Are you hosting on Apache or some other server?

Yes Its apache running. I need to know if adding www in certificate can change the Site SEO ranking?

SEO is a totally different subject, but search engines give “weight” to sites using encryption.
LE will be issuing wildcard certificates for domains. I know there is someone that knows more on this subject… But take a look at [https://letsencrypt.org/2017/12/07/looking-forward-to-2018.html] in regard to that.
Apache has configuration guides to assist in setting up your virtual hosts dealing with your issue. (I had a similar problem) Look at https://httpd.apache.org/docs/2.4/vhosts/name-based.html … you should be able to browse to wordsuccor.com, or www.wordsuccor.com before you configure a cert.
Try running “certbot certificates” from the command line to determine what domain info certbot sees. (the output may help)
apachectl -S should show you the vhosts… if you don’t see wordsuccor.com in the output, there’s a need to reconfigure your subdomain. (off topic here I think)
The output from apachectl -S and certbot certificates should reveal the fundamental issue holding you up.

If you are already set up, try removing the port redirect in your vhost config or your httpd.conf

Hope this helps a bit.

Thank you very much. how ever I keep getting certbot certificates : command not found

Since you won't tell us how you obtained the cert in the first place, we really can't tell you how you should proceed to change the cert.

I installed the ssl following this
https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/

I swear it’s like pulling teeth. As the questions you ignored in your initial post ask, what exact command did you run to issue the certificate(s)?

This was the command I remember

​./certbot-auto certonly --webroot -w /home/bitnami/apps/wordpress/htdocs/ -d example.com -d www
.example.com

If that's what you ran, then your certificate should cover both example.com and www.example.com--but since you've not given your domain name, we can't tell if it does or not.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.