Challenge works in browser, but getssl ACME client complains


#1

I’m trying to successfully set up my domain with SSL using letsencrypt, getssl (bash acme client) and a synology nas running DSM 6.2 and nginx. I’m configuring everything manually, as I need to have full control over the nginx configuration. (I’m not using the built in webstation GUI to configure this site)

My domain is: tripster.nu

I ran this command:
./getssl tripster.nu

It produced this output:
tripster.nu: Certificate on remote domain does not match, ignoring remote certificate
Registering account
Verify each domain
Verifying tripster.nu
copying challenge token to /***/.well-known/acme-challenge/-_eh6w1_VmYcX0ECYgr_qy1ukDJZnhJWd74CGPFcFYw
getssl: for some reason could not reach http://tripster.nu/.well-known/acme-challenge/-_eh6w1_VmYcX0ECYgr_qy1ukDJZnhJWd74CGPFcFYw - please check it manually

My web server is (include version):
nginx version: nginx/1.13.3
TLS SNI support enabled

The operating system my web server runs on is (include version):
Synology DSM 6.2
I can login to a root shell on my machine (yes or no, or I don’t know):
yes


#2

Try set SKIP_HTTP_TOKEN_CHECK to true. Might just be a case of the server can’t access the URL locally, which can be safely ignored under some circumstances.


#3

Thanks! that was indeed the issue!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.