Challenge failed for domain

Ubuntu 16+nginx
I request a certificate with the command
sudo / usr / local / bin / certbot-auto --nginx and see fail:

nginx: [warn] conflicting server name “” on, ignored
Waiting for verification…
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.


On an identical server, everything turned out. Help me please. What i do not rigth?

Hi @armeez88


is your problem. You have duplicated vHosts.

What says

nginx -T

Please share the complete output. And answer the following questions:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

www@localhost:~$ nginx -T
nginx: invalid option: “T”

Same as sudo? If yes, your nginx is too old.

That's not longer supported. But you have more then one combination of port 80 and server name.

If nginx -T doesn't work, check your configuration manual to find these duplicated vHosts. Merge these in one config file, restart your nginx. Then it may work.

Or switch to webroot.

I have 3 vhosts: .ru, .com, .cn.

But on other server i have vhosts like that and certbot worked ok

The problem has been resolved. I remove

listen 80;

from sites-enable config and it work!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.