Challenge failed for domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:cxertbot --nginx -d

It produced this output:Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Starting new HTTPS connection (1):
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
nginx: [warn] conflicting server name “” on, ignored
Waiting for verification…
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.


My web server is (include version):nginx version: nginx/1.12.2

The operating system my web server runs on is (include version):centos 7.3

My hosting provider, if applicable, is:cloudflare

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.34.2

Hi @Malhar

there is your problem.

Check your vHost configuration

nginx -T

Looks like you have a duplicated port 80 definition. Merge the multipe vHosts port 80 with the same server name to one vHost, then restart your nginx.


thanks a lot… problem solved


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.