CERTSAGE - Can't force HTTPS?

My domain is: www.mummieswaiting.com

I ran this command: You cannot activate HTTPS Redirect because AutoSSL is not currently active for this domain or the SSL certificate is not valid.

It produced this output: No idea what this is

My web server is (include version): No idea what this is

The operating system my web server runs on is (include version): No idea what this is

My hosting provider, if applicable, is: TSO Host

I can login to a root shell on my machine (yes or no, or I don't know): No idea what this is

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Yes, TSO new CPanel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): No idea what this is

TSO Host told me i had to switch from their old Gridhost to the new Cpanel.
I've spent 2 days switching and now I dont' have an SSL Cert. Found out this is becuase they no longer support lets encypt.
So I followed this amazing guide and got a cert CertSage ACME client (version 1.2.0) - easy webpage interface, optimized for cPanel, no commands to type, root not required

However the last step says ' 1. Switch Force HTTPS Redirect to On.' But I can't do this becuase 'You cannot activate HTTPS Redirect because AutoSSL is not currently active for this domain or the SSL certificate is not valid.' (You just can't click the button at all!)

Is there ANY way I can make this happen? I refuse to pay TSO for a cert when they've been so terrible, but if I do my own any other way then users still get the security warning before entering.

2 Likes

You can achieve the same by putting this in your main .htaccess file:

RewriteEngine On
RewriteBase /

RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

(maybe 308 instead of 301)

4 Likes

Welcome to the Let's Encrypt Community, Jade! :slightly_smiling_face:

While @9peppe has proposed a reasonable alternative, I think there's something you missed to cause the original approach to not work.

Looking at the latest certificate you acquired, I can see that it covers www.mummieswaiting.com, but not mummieswaiting.com. Please acquire and install a new certificate with mummieswaiting.com on the first line in the domain box and www.mummieswaiting.com on the second line in the domain box then try the Force HTTPS Redirect toggle again.

4 Likes

Thank you both for your replies!
I've tried both pieces of code as well as a few others and none are doing the job.

My host has recomended installing the 'really simple SSL' plugin, however I use google authenticator to log in to wordpress back end. As the login page is not secure like the rest of my site, GA wont work, so I have no way of login in and installing this.

@griffin I tried to do this with both www.mummieswaiting.com and mummieswaiting.com but the new certificate isn't showing, it just keeps showing the one i made earlier today?

3 Likes

When I try to get the certificate again it says 'A staging certificate was acquired. It was not saved to prevent accidental installation.' I assume this is why it isn't showing?

2 Likes

This has now worked, thank you so much! It took me many attempts but I managed to get it to cover both and It's now working!

Does the cert auto renew do you know?

4 Likes

certsage certs don't auto renew.

5 Likes

But the renewal process can be made much faster by upgrading to version 1.3.0.

5 Likes

Is there a tutorial somewhere on how to upgrade? I only set it up yesterday so I would have assumed I was updated!

1 Like

At the top of the page for CertSage 1.2.0, there is a link to the page for CertSage 1.3.0. Upgrading is usually as simple as downloading the new certsage.txt to replace your existing certsage.php copy/copies. If you've modified certsage.php (e.g. changing the location where $dataDirectory points), you will need to make that modification in the new certsage.php copy/copies. Your existing account key(s) and other data files in the data directory will automatically be used by the new version. I will (hopefully very soon) be releasing a couple of minor tweaks to version 1.3.0 that further simplify the usage of CertSage. :slightly_smiling_face:

4 Likes