[CERTSAGE] Acme Challange errors

Any advice or work around for this error?

My domain is: zrgs.net

I ran this command: Using certsage

It produced this output:
Invalid response from http://zrgs.net/.well-known/acme-challenge/LcYfHX9I4-oEAnXIIZiiM1qiU5cTRaNzge7y1ZDPsX8: 404

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
Namecheap Hosting
I can login to a root shell on my machine (yes or no, or I don't know):
don't know
I'm using a control panel to manage my site YES

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):certsage 1.4.1

1 Like

Welcome to the Let's Encrypt Community :slightly_smiling_face:

Looks like you've got some rewrite rules that are adding an unnecessary forward slash to requested URLs.

http://zrgs.net/certsage.php
301 Moved Permanently
https://zrgs.net/certsage.php/
404 Not Found

For this one, I'm initially suspecting that similar rewrite rules are interfering with serving the challenge file:

http://zrgs.net/.well-known/acme-challenge/LcYfHX9I4-oEAnXIIZiiM1qiU5cTRaNzge7y1ZDPsX8
404 Not Found

The challenge file is removed by CertSage each time it runs as part of its cleanup effort, so I recommend manually putting a test file in .well-known/acme-challenge then working on getting that test file successfully served.

6 Likes

Thanks for the quick response. Problem solved. Directory structure on the server required the script file to be in a different sub-directory..

6 Likes

:partying_face:

I love a happy ending!

6 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.