Certificate verified from?

#1

Hello,

I was able to renew my certificate, all OK, but…

The certifictae has been verified from:
CN=MTQwMm 2,C=EN
Who is: “MTQwMm 2”?
Usually it should be there “letsencrypt”…

Could you please let me know if this is valid name of (your) letsencrypt company?

My domain is: msgsolutions.eu

I ran this command:
[root@psms04 inst]# ./certbot-auto
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?


1: api.msgsolutions.eu


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1
Obtaining a new certificate
Deploying Certificate to VirtualHost /etc/httpd/conf/httpd.conf

Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.


1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you’re confident your site works on HTTPS. You can undo this
change by editing your web server’s configuration.


Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2
Enhancement redirect was already set.


Congratulations! You have successfully enabled https://api.msgsolutions.eu

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=api.msgsolutions.eu


IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/api.msgsolutions.eu/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/api.msgsolutions.eu/privkey.pem
    Your cert will expire on 2019-05-28. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot-auto
    again with the “certonly” option. To non-interactively renew all
    of your certificates, run “certbot-auto renew”

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

Thank you

best
Milan Malbasic

#2

Where do you see that certificate?

When I connect to api.msgsolutions.eu, I do not see it.

#3

try to acces https://api.msgsolutions.eu/coin/index.cgi.
the site is still not working as expected, you’ll get http 500 but this is not the problem.
the problem is when you acces the mentioend URL and then you click on the certificate information you see the CN=MTQwMm 2,C=EN

#4

image

#5

Sometimes browsers cache the wrong certificate info. Try re-opening the tab.

1 Like
#6

will try it fro manother PC.
Now I stil lsee following:
grafik

#7

Curiously the validity period looks identical.

Are you perhaps on a corporate network with an interception proxy. or antivirus, or anything like that?

Is the IP address of the domain from the perspective of that PC equal to 85.31.186.86 ?

1 Like
#8

Hi @mmalbasic

both addresses use the same certificate ( https://check-your-website.server-daten.de/?q=api.msgsolutions.eu and https://check-your-website.server-daten.de/?q=api.msgsolutions.eu%2Fcoin%2Findex.cgi ):

CN=api.msgsolutions.eu
	27.02.2019
	28.05.2019
expires in 90 days	api.msgsolutions.eu - 1 entry

So it isn’t a “mixed configuration”, one server handles /, the other /coin/

Has your PC with the wrong picture a changed host file?

C:\windows\system32\drivers\etc\host

with a changed ip?

What shows “Zertifizierungspfad”?

PS: Oh, not seen:

Your / has a 403 - Forbidden. Your /coin/ has a http status 500 - Internal Server Error. Is that part of the problem? Perhaps a redirect to an internal server if the user is local?

#9

Hallo Jürgen,

The “problem” is actually not a problem. :slight_smile:
I just tried from the office, from another PC/browser and have right infos:

1 Like
#10

There probably was another data in cache in previous “schleppi” (notebook).
btw: the 500-er error is actually cause I still didn’t finish to complete the site and somewhere in the (perl) code is a bug :slight_smile:
but it doesn’t have anyithing to do with the certificate.
So the topic can be closed from my point of view.

And: very important:
THANK YOU ALL for your help and suggestions. it’s really highly appreciated .
best
Milan

2 Likes
closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.