Fail renewal letsencrypt

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

https://crt.sh/?q=mmgmobile.com

My domain is: mmgmobile.com

I ran this command: ./letsencrypt-auto renew

It produced this output: ‘/etc/letsencrypt/live/mmgmobile.com/fullchain.pem’ does not exist or is empty
(I have nothing in: /etc/letsencrypt/live/)

My web server is (include version): Apache2

The operating system my web server runs on is (include version): debian

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.28.0

So far everything works perfectly but this time I find myself with this error.
I have absolutely nothing to change or modify on my server.

thank you in advance for your help and advice.

1 Like

Hi @MMG

why is there nothing?

There are checks of your domain, ~~ one hour old - https://check-your-website.server-daten.de/?q=mmgmobile.com

With a lot of older certificates. So it isn't your first certificate.

Run it as root / sudo.

1 Like

following a problem with my forum, i had to do a complete reinstallation but server side everything is fine.

but I do not understand why I have nothing left in the folder / etc / letsencrypt / live /

on the other hand in the folder /etc/letsencrypt.backup/ there is apparently everything that should be in the folder / etc / letsencrypt /

I try to make a copy of the files in /etc/letsencrypt.backup/ to / etc / letsencrypt but it is unsuccessful.

as you may have seen it’s actually not my first certificate and until now everything goes well.

I tried as usual with the command sudo and after a failure I tried with the user root.

  1. I will try a method, give a permanent redirection HTTPS => HTTP so that my site is always accessible compared to the end of the certificate that ends tomorrow.

  2. To completely uninstall the ssl certificate.

  3. then do a clean installation of a new certificate.

but I’m not sure it works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.