Certificate valid but flagged by Chrome as "Not secure"

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: rpxy.digicard.net

I ran this command: N/A

It produced this output: N/A

My web server is (include version): Webmin (Apache) and Teleport

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: Hostinger

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Webmin

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I don't know


I have a VPS on Hostinger running Webmin and Teleport, both apps manage their Lets Encrypt certificates. Apparenttly those certificates are valid but Chrome flags them as "Not Secure".

If I open those pages on another browser (Safari) or in a Chrome Incognito window they validate ok.

Any hint?


I think you just need to use https://rpxy.digicard.net:10000 instead

That domain does not redirect HTTP requests to HTTPS. So, add that or explicitly use https://


It actually does, using JavaScript:

<p class="err-content">This web server is running in SSL mode. Try the URL <a href='https://rpxy.digicard.net:10000/'>https://rpxy.digicard.net:10000/</a> instead.<script>if (location.protocol != 'https:') {  location.protocol = 'https:';}</script></p>

I can't log in obviously, but the login page seems to be just fine. Maybe your Webmin has trouble with mixed content? Check your Chromes developer toolbars console to see more info.


It says "Certificate is valid", so this is loaded over HTTPS.

I think this is a mixed-content warning.

I'm not familiar with Webmin, but if there's some way to add content to a page, you can use CSP to upgrade requests:

  content="upgrade-insecure-requests" />

Put that before any other resources are included in the page.


Hi everybody!

Thanks for your help!

The issue is not confined to Webmin, the same problem is shown on Teleport page rpxy.digicard.net:443

Accesing https://rpxy.digicard.net:10000 makes no difference. Same warning.

It look more like a browser problem, some caching of an older certificate somewhere. Both site loads fine from another browser (Safari) or from an Chrome incognito window (no cache nor cookies) but I'm unable to pinpoint the source of the error.


As Osiris noted earlier, the Chrome DevTools should show more details. These are already in Chrome so nothing to install. The Network section might be the right tool section. Either Activity or Page Resources is where I would start


The console makes note of mixed content.


I see now. Security section too looks like. I vaguely remember items being flagged in Network as well but Console or Security look better options


I agree with regard to the Security tab, that one is also pretty good for mixed content.


This is what Chrome Security Console tab shows, but I don't know how to interpret it


Fixed with this !!!

Thank you guys!!!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.