Certificate Not Valid

My domain is: https://i.twobrake.xyz

I ran this command: certbot certonly --standalone --register-unsafely-without-email --agree-tos -d "$HOSTNAME" --non-interactive

It produced this output: It said that the certificate was successfully registered, but it still says the certificate is not valid on my website.

My web server is (include version): Unknown.

The operating system my web server runs on is (include version): Ubuntu.

My hosting provider, if applicable, is: https://hostinger.com for the website and https://oxide.host for the virtual private server.

I can login to a root shell on my machine (yes or no, or I don't know): Yes.

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

You're using the --standalone authenticator plugin without an installer plugin: how did you install the certificate?


All I know is that it said it was successfully registered. Maybe I need to install it and then retry the command, but then it says the certificate is not ready for a renewal. I also checked this website out and I think the certificate is registering to the wrong domain for some reason. SSL Checker. Maybe it is because I am using a virtual private server to connect to my domain, but I am pretty sure I connected the DNS record to the correct IP.

The way you're running certbot now will only fetch the certificate: it's nothing more than a file on your server currently. The webserver isn't automatically configured to actually use the certificate.

Why are you using the standalone plugin without an installer plugin anyway? Also, howcome you don't know the webserver you're using if your website is hosted on a private server?


Well, I am hosting my domain on https://hostinger.com and connecting my virtual private server to my sub domain hosted by https://oxide.host. How would I activate the certificate?

If you'd answer my questions, we might be able to help you with that


My hosting provider just told me to run the command as is, didn't tell me anything about a installer plugin. I know this question seems quite vague, but what do you mean by what webserver type?

The webserver running your website needs to be instructed to use your certificate. Without knowing which software is being used, it's impossible to go beyond very generic instructions as "Configure your webserver to actually use the certificate."

Also, if your hosting provider provided you the certbot command, can't they help you with the rest of the process? They must have known using only --standalone would not be enough...


I am using Apache/2.4.41 (Ubuntu) for my webserver. Also, my hosting provider never told me about any further commands to run after the one I inputted.

1 Like

If you're using Apache and you're running certbot from your virtual private server, I'd recommend against using the standalone plugin (why would they advice that?!?), but use the apache plugin:

certbot --apache -d "${HOSTNAME}"


I got this error.

You shouldn't use the $ and {/} if you're manually substituting the HOSTNAME variable.


Which option do I select?

Which option do you see? I (and I'm pretty sire my fellow Community volunteers too) am not psychic.


Sorry about that, for some reason the images don't upload on the first try. I just edited the message.


You can try to reinstall the certificate. No need to reissue a new one. Let the apache plugin do its work with the currently issued cert and hope your Apache configuration is compatible.


I got this prompt now, sorry for asking so much. I just don't understand what to do here really.


Is your Apache already configured for your website? To me it looks like a generic configuration without anything specific for your hostname.

I'm not sure if your current configuration is suitable.


I don't think I have edited the configuration file yet. Is it needed? If so, where is the configuration file?

It's in principle not required for a HTTPS certificate, but it might not be possible for the apache plugin to update your configuration if it can't find the hostname used in your certificate.

You might try to select option 3 in your recent image, but I'm not sure if it'll work.