Help new Certificates

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot certonly --standalone -d

It produced this output: Requesting a certificate for

Certbot failed to authenticate some domains (authenticator: standalone). The Certificate Authority reported these problems:
  Type:   unauthorized
  Detail: Invalid response from 404

Hint: The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet.

Some challenges have failed.
Ask for help or search for solutions at See the logfile C:\Certbot\log\letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):

The operating system my web server runs on is (include version): 10.0.22621 N/A Build 22621

My hosting provider, if applicable, is: Microsoft Azure

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):certbot --version

First, if you want a certificate to cover then that should be the domain name in the certbot command (and not just

Second, you have an nginx server responding to HTTP (port 80) requests right now. The --standalone option needs exclusive use of port 80 so won't work with nginx using that port.

You need to either stop nginx or use the --webroot method to rely on the existing nginx to satisfy the HTTP Challenge.

I see you already have a working HTTPS connection to your data domain (apart from its expired cert) so you should avoid using the --nginx method unless you also use it with certonly



❯ curl -IL
HTTP/1.1 404 Not Found
Server: nginx/1.19.1
Date: Thu, 21 Sep 2023 21:01:42 GMT
Content-Type: text/html
Connection: keep-alive

Are you running Certbot on the same machine your domain is pointing to?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.