Certificate is not valid

I run a certbot

My domain is: demo.wellcast-roi.com

I tried to access https://demo.wellcast-roi.com, but it shows me that certificate is not valid.

Screenshot 2023-08-22 at 11.05.18

I run at APACHE server at Centos 7.

How can we fix this?

You are using a certificate from the Let's Encrypt Staging system. It is great you used that to test but you must get a production certificate for actual use. See your cert details here:

How did you obtain the certificate? Please answer as much as you can from the form you were shown


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


Thanks, here it is...

I ran this command: certbot certonly -a manual -d demo.wellcast-roi.com --preferred-challenges dns --staging

OUTPUT I do not have here, but we can get certificates.

My Web server is: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips

My server is running: CentOS Linux release 7.9.2009 (Core)

My hosting provider, if applicable, is GCP

I can login to a root shell on my machine

The version of my client is certbot 1.11.0

Re-run the command without --staging to get a production cert


Thanks for your help. It is work!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.