Certificate expired auto renew not happening


#1

Hi my certificate has expired a day ago
and i am trying to renew it but nothing helps
even the auto renew is not helping
please guide me here


#2

Hello. :slightly_smiling_face: Please provide more information.


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#3

domain: highwaydelight.in
sudo certbot renew --dry-run
i stopped apache and and run above command and restarted the apache server
operating system is ubuntu 16.04
i can log into my root


#4

i got this output
new certificate deployed without reload, fullchain is
/etc/letsencrypt/live/highwaydelight.in/fullchain.pem


** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates below have not been saved.)

Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/highwaydelight.in/fullchain.pem (success)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)


#5

Hi @manojrammurthy,

--dry-run means something like “test” or “experiment” and it’s meant for use to see if your configuration would work for a renewal. If you want to renew the certificate, you should instead use certbot renew, without the --dry-run option.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.