Certificat pas complètement fonctionnel

Veuillez remplir les champs ci-dessous pour que nous puissions vous aider. Remarque : vous devez fournir votre nom de domaine pour obtenir de l’aide. Les noms de domaine des certificats émis sont tous rendus publics dans les journaux de Transparence de Certificat (par exemple, https://crt.sh/?q=example.com). Par conséquent, le fait de ne pas indiquer votre nom de domaine ici n’aide pas à le garder secret, mais rend plus difficile pour nous le fait de vous aider.

Je peux lire des réponses en Anglais :

Mon nom de domaine est : e-depannages.ch

J’ai exécuté cette commande :

Je reçois un message d’erreur d’ovh en disant que mon certificat n’est pas complètement actif.
J’ai donc essayé de désinstaller le certificat, mais impossible
impossible non plus de réactiver toutes les options car il est indiqué que j’ai trouvé activé de licence or ce message apparaît depuis plus d’une semaine.
Du côté d’ovh ils disent que tout est ok, mais c’est faux

comment résoudre le problème ?
merci pour votre aide

Elle a produit cette sortie :

Mon serveur Web est (inclure la version) : apache

Le système d’exploitation sur lequel mon serveur Web s’exécute est (version incluse) : wordpress

Mon hébergeur, le cas échéant, est : ovh (plesk)

Je peux me connecter à un shell root sur ma machine (oui ou non, ou je ne sais pas) : je ne sais pas

J’utilise un panneau de configuration pour gérer mon site (non, ou fournit le nom et la version du panneau de configuration) : oui

Pouvez vous donner le message exact ?

Le site e-depannages.ch utilise bien actuellement un certificat Let’s Encrypt, valide jusqu’au 17 janvier 2020 (je suppose que OVH gère le renouvellement automatique

Par contre, il y a bien un soucis de “mixed content” (https://developer.mozilla.org/fr/docs/Sécurité/MixedContent/regler_probleme_contenu_mixte_site_web)

Il faudrait remplacer les appels à ces images “http” par “https”.

1 Like

Le mer. 23 oct. 2019 à 15:18, Frédéric BILLHARZ frederic@billharz.com a écrit :

Cela signifie que vous avez généré plus de 5 certificats identiques en moins de 7 jours. Cette erreur devrait donc disparaitre dans au maximum 7 jours.

Vous avez actuellement un certificat valide, vous n’avez à priori pas besoin d’en générer un nouveau à l’instant.

Merci pour l’info.

Malheureusement, cela fait plus de 7 jours que j’essaie d’installer le certificat et wordpress m’a TOUJOURS indiqué qu’il n’y avait pas de certificat alors que je tape https et mon site cela fonctionnait.

je suis perplexe face à cette situation.

Le jeu. 24 oct. 2019 à 00:33, Tom via Let’s Encrypt Community Support letsencrypt@discoursemail.com a écrit :

Il ne semble pas y avoir de soucis avec le certificat actuellement installé pour e-depannages.ch.
Il est possible que wordpress ne soit pas au courant du https, que ce soit apache qui fasse le nécessaire.

Il faudra simplement penser à bien vérifier que le renouvellement se passe bien (généralement un mois avant expiration du certificat)

Important : ne pas chercher à révoquer un certificat dans votre situation pour essayer de corriger des problèmes (sauf en cas de compromission du serveur ou de la clé privé), le révoquer n’a aucun effet sur le certificat installé.

merci beaucoup pour votre aide

mais en fait le problème perdure depuis des mois et je m’en occupe que maintenant

donc en attendant que le certificat se renouvelle cela ne va pas changer j’essaye donc un moyen peut-être désinstaller Wordpress mais j’ai un peu peur que cela pose un problème dans la base je suis sur place et je ne suis pas le plus fin des experts

on peut restaurer wordpress mais une base ? certainement mais alors comment

Le jeu. 24 oct. 2019 à 18:42, Tom via Let’s Encrypt Community Support letsencrypt@discoursemail.com a écrit :

Mon conseil si vous devez faire des tests, faites le sur un autre serveur, avec un autre nom de domaine (ou un sous-domaine).
Après, n’était ni expert wordpress, ni ne connaissant le détail de votre configuration, je ne suis pas sur d’être d’une grande aide pour la suite. Il me semble simplement que si c’est l’interface d’admin OVH qui gère le certificat SSL/TLS, il est normal que wordpress ne s’en occupe pas.

Bonjour

je ne sais pas où m’adresser pour régler mon problème.

il apparaît que mon certificat est désactivé sur mon plesk, or sur le site (en construction) https://billharz.com le cadenas y figure.

Comment faire ?

Merci d’avance pour votre aide