Certbot unrecognized arguments error when using cloudflare-dns plugin


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: ./certbot-auto certonly
–server https://acme-v02.api.letsencrypt.org/directory
–dns-cloudflare
–dns-cloudflare-credentials
–text --csr $CSR_Path

It produced this output: Requesting to rerun ./certbot-auto with root privileges…
usage:
certbot-auto [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] …

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: unrecognized arguments: --dns-cloudflare-credentials $credentials_Path --dns-cloudflare-propagation-seconds 60

My web server is (include version): N/A

The operating system my web server runs on is (include version): N/A

My hosting provider, if applicable, is: DNS through Cloudflare

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Hi,

Did you install & compile the dns-cloudflare plugin with your certbot-auto installiation?

If not, you would need to download & install the plugin.

Thank you


#3

I installed Certbot via cloning the git repo and then ran the following commands:

~/git-repos/certbot$ python setup.py install
cd certbot-dns-cloudflare
python setup.py install

After that, I tried rerunning the original command, with the same result.


#4

certbot-auto isn’t really designed to work with the DNS plugins, though it’s not impossible to set up.

What OS (including version) are you using?


#5

I’m running Raspberian on a RasPi, installed with NOOBS version 2.8.2, released 2018-06-27.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.