Certbot: error: unrecognized arguments: --dns-azure-config

Hi everyone,
I want to get certificate, by using Azure DNS Authenticator plugin, but i get this los

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: unrecognized arguments: --dns-azure-config /root/.secrets/certbot/azure.ini

Here's log, which plugins are avaible:

certbot plugins --text
Saving debug log to /var/log/letsencrypt/letsencrypt.log


  • dns-cloudflare
    Description: Obtain certificates using a DNS TXT record (if you are using
    Cloudflare for DNS).
    Interfaces: IAuthenticator, IPlugin
    Entry point: dns-cloudflare =
    certbot_dns_cloudflare.dns_cloudflare:Authenticator

  • standalone
    Description: Spin up a temporary webserver
    Interfaces: IAuthenticator, IPlugin
    Entry point: standalone = certbot.plugins.standalone:Authenticator

  • webroot
    Description: Place files in webroot directory
    Interfaces: IAuthenticator, IPlugin
    Entry point: webroot = certbot.plugins.webroot:Authenticator


But i installed Azure plugins:

snap list
Name Version Rev Tracking Publisher Notes
bare 1.0 5 latest/stable canonical✓ base
certbot 1.31.0 2414 latest/stable certbot-eff✓ classic
certbot-dns-azure 1.5.0 1 latest/edge terrz -
certbot-dns-cloudflare 1.31.0 2029 latest/stable certbot-eff✓ -

I will add that in the past i have same problem with Azure, but then I fixed it somehow

Any ideas?

Hi @Grucha, and welcome to the LE community forum :slight_smile:

Please show:
certbot --version

How did you install?:

2 Likes

certbot 1.31.0

via snap
snap install --edge certbot-dns-azure

I'm not that familiar with snap (luckily), but the lack of the "checkmark" at the azure plugin caught my eye. Any idea what that means to begin with?

Also, if you look at the wildcard tab on the Certbot installation instructions (Certbot Instructions | Certbot -> click on the "wildcard" tab at the top), you see an extra snap command regarding plugins (at "Step 8"). Did you also run that command?

3 Likes

It means verified publisher. It has no effect.

I agree that @Grucha probably has forgotten to run:

sudo snap set certbot trust-plugin-with-root=ok
sudo snap connect certbot:plugin certbot-dns-azure
4 Likes

Hm, is this really necessary? Because I couldn't find that command on the snap instructions at certbot.eff.org.

4 Likes

It's because the official plugins no longer require it.

5 Likes

Ah, but third party plugins do, OK, good to know, I'll bookmark your post for future reference :grin:

4 Likes
sudo snap set certbot trust-plugin-with-root=ok

I did this, because i'm using too cloudflare plugin

sudo snap connect certbot:plugin certbot-dns-azure

I've tried it too, but result is

An unexpected error occurred:
pkg_resources.ContextualVersionConflict: (cryptography 38.0.1 (/snap/certbot/2414/lib/python3.8/site-packages), Requirement.parse('cryptography<38,>=0.6'), {'msal'})
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /tmp/certbot-log-zbj_hs_l/log or re-run Certbot with -v for more details.

This is strange, because two months ago I tested it on a test machine and had a similar problem, but then I found a solution on the web and now nothing works

Here's documenation for Azure
https://certbot-dns-azure.readthedocs.io/en/latest/

Ah, sorry. That Azure plugin currently has an issue that the author hasn't had a chance to address yet, but there's a workaround in that link.

If that doesn't work out, you could also consider a different plugin (authored by me) which supports Azure on Certbot.

4 Likes