Certbot renewal : fails due to too many pending authorizations (SAN cert, pass on staging)


#1

Please fill out the fields below so we can help you better.

My domain is:
www.genevarepresentatives.com (and another few dozen)
I ran this command:
certbot renew

It produced this output:
:warning:certbot.renewal:Attempting to renew cert from /etc/letsencrypt/renewal/www.genevarepresentatives.com.conf produced an unexpected error: urn:acme:error:rateLimited :: There were too many requests of a given type :: Error creating new authz :: too many currently pending authorizations. Skipping.
My operating system is (include version):
Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux
My web server is (include version):
apache 2.4
I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel
no, cli

Dear all,

I ve run into an issue that I’ve been trying to fix for the past week but I am soon out of time to renew my certs. I have a host with a few dozen of websites (different domains) (60+) most of them are agglomerated into one big cert. When I run the certbot renew, it used to work, but for the past month, if fails with a " too many currently pending authorizations “. there was an issue with a certain website failing due to being blacklisted (that is cleaned now) and was preventing the renewal. but now if I run with --dry-run it works without error. however when I do it on live, after a dozen or 2 domains challenge issued (all within the same certificate) it fails with " too many currently pending authorizations” error. this occur when I let it rest for 24h? then if I try to run again right after it, it doesn’t even start issue the challenges, it immediately hit the " too many currently pending authorizations" error and I am stuck waiting for another round of tests (the dryrun always works).

I thought that renewing cert that were already issued were not subjected to rate limitation ?

please help me out :slight_smile:

Michael


#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.