Certbot + Openfire - HTTP-Binding doesnt work

I have installed Openfire 4.5.1 on Debian 9. I was upgrading from a earlier version but even Reinstalling the whole System didn’t help. After setting up Openfire everything works fine - sending images in Conversations, … The only problem is the self-signed certificate. I want to use a Letsencrypt Cert. But after uploading the files with help of the Certificate Manager, the Http-Binding function is disabled. It can’t be enabled anymore. Deleting the Signed Letsencrypt certificate and using the self-signed again doesn’t help. Has anyone an idea what to do? How do i have to setup certbot for openfire?

is this relevant?

The Certs are trusted. Everything is working fine except from Http-Binding (Sending Files etc.)

Hi @fbn172

I’m not firm with that configuration.

But is this a bug? Or is it a feature? May be that environment says: “https defined -> disable http”.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.