Certbot issue on Ubuntu 20.04

My domain is: casts.king.fyi

I ran this command: certbot --nginx -d casts.king.fyi

It produced this output:

root@alpha:/var/log/letsencrypt# certbot  --nginx -d casts.king.fyi
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
An unexpected error occurred:
AttributeError: module 'acme.challenges' has no attribute 'TLSSNI01'
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version): nginx/focal,now 1.17.10-0ubuntu1

The operating system my web server runs on is (include version):

NAME="Ubuntu"
VERSION="20.04 LTS (Focal Fossa)"

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.40.0

1 Like

What’s the version of the python3-certbot-nginx package?

1 Like

python3-certbot-nginx/focal,now 0.39.0-1

Not seeing any available updates in apt.

No, that’s the latest version indeed. And the package python3-acme? And the contents of /var/log/letsencrypt could be helpful too.

1 Like

Hmm, the workaround here worked for me. Should hold me over until the package is updated.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.