Certbot is successful but site is still not secure

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: larrybuffaloboy.com

I ran this command: certbot --apache

It produced this output:

Deploying certificate
Successfully deployed certificate for www.larrybuffaloboy.com to /etc/apache2/sites-enabled/larrybuffaloboy.com-le-ssl.conf
Congratulations! You have successfully enabled HTTPS on https://www.larrybuffaloboy.com

My web server is (include version): Apache/2.4.29 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.3 LTS

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 2.5.0

Hi @tronicdata, and welcome to the LE community forum :slight_smile:

Please show this file:


I fixed this using chatgpt. First I was able to read my cert:

openssl x509 -in /etc/letsencrypt/live/yourdomain.com/cert.pem -noout -text

Then I assumed maybe the issue was that my domain was listed with 'www' prefix as the common name. So to remedy that, I needed to remove the certs I had listed:

sudo certbot certificates

Then delete with:

sudo certbot delete --cert-name yourdomain.com

Also removed conf files from /etc/apache2/sites-available/, then recreated the conf:

sudo nano /etc/apache2/sites-available/domainname.com.conf
<VirtualHost *:80>
    ServerName domainname.com
    ServerAlias www.domainname.com
    DocumentRoot /var/www/html

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

Restarted Apache:

sudo systemctl restart apache2

Recreated the certs:

sudo certbot --apache -d larrybuffaloboy.com -d www.larrybuffaloboy.com

Restarted Apache again:

sudo systemctl restart apache2

Site is now recognizing the cert and is secured. I also had to change the documentroot of /etc/apache2/sites-available/domainname.com.conf to point back to the correct url.

Thanks! Hope that helps someone

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.