Certbot - Incorrect Domain Specified so TLS-SNI Challenge Fails


#1

Please fill out the fields below so we can help you better.

My domain is: patchvault.org

I ran this command: ./certbot-auto --apache (also tried the ./letsencrypt-auto --apache -d patchvault.org

It produced this output:

[root@athena jathayde]# ./certbot-auto --apache
/root/.local/share/letsencrypt/lib/python2.6/site-packages/cryptography/__init__.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of cryptography will drop support for Python 2.6
  DeprecationWarning
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Which names would you like to activate HTTPS for?
-------------------------------------------------------------------------------
[...]
52: patchvault.org
53: www.patchvault.org
[...]
-------------------------------------------------------------------------------
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel):52
Obtaining a new certificate
Performing the following challenges:
tls-sni-01 challenge for patchvault.org
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. patchvault.org (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Failed to connect to 198.101.243.210:443 for tls-sni-01 challenge

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: patchvault.org
   Type:   connection
   Detail: Failed to connect to 198.101.243.210:443 for tls-sni-01
   challenge

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

My operating system is (include version): centos-release-6-8.el6.centos.12.3.x86_64

My web server is (include version): Apache/2.2.15 (Unix)

My hosting provider, if applicable, is: Rackspace Cloud (VM)

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

I’m sure this is user error on my part.
I can access the domain both wiht http and httpd from a browser (httpd throws the “invalid cert” warning).
I’ve tried this enough that i’m in a lockout state right now:

An unexpected error occurred:
There were too many requests of a given type :: Error creating new authz :: Too many invalid authorizations recently.
Please see the logfiles in /var/log/letsencrypt for more details.

#2

Solution was that I was requesting for “patchvault.org” but the certificate was issued for “www.patchvault.orgheaddesk Hope this helps someone else in the future.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.