Certbot hangs. So does Snappy

My domain is:
sittingduckpodcast.com (probably not working currently, but kinda beside the point for this issue)

I ran this command:
certbot certificates

It produced this output:
It hangs

My web server is (include version):

The operating system my web server runs on is (include version):
AlmaLinux 8.5

My hosting provider, if applicable, is:
DigitalOcean VPS

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
Cannot determine certbot version. Snappy is 2.53.4-1.el8.

I think this is probably an issue with Snappy, but figure this is as good a place to ask as any. I went to add a new certificate for the above-named domain, but the command hung. I next tried certbot certificates and this also hung!

Thinking this very odd, I next tried to see if Certbot had been updated recently, which was when I encountered the problem that the snap command also hangs on every command except help.

I had just done a dnf update on the server and rebooted it. The /var/log/letsencrypt.log showed there had been successful activity within the 24 hours before I discovered the issue, but there has been none since (now several days). I have confirmed the snapd daemon is running and can find no errors in /var/log/messages relating to it, nor with journalctl.

I have no clues as to what is causing this, so am rather stuck. The only next step I can think of without any further clues is to uninstall and reinstall Snappy and certbot. Not sure what this will mean for my other sites (on the same server) that currently have valid certificates.

Yeah, certbot hanging is most likely a snap or system issue. Have you tried the snapcraft forums? I saw a similar problem there using AlmaLinux and even your version of snap:

I know the title says RHEL but the second poster with a "me too" was using Alma

If that is not exactly your problem perhaps some of their debugging steps will help clarify your problem.

Reinstalling certbot should have no effect on your cert folders. Just don't delete them.

Oh: and welcome to the community @zkarj


Thanks! I tried the stuff mentioned there and did get it working, though it did not survive a reboot. It does seem like the next snap version addresses the problem so hopefully that will land soon.

At least I have somewhere to look now (I'm looking at you, SELinux!) I should have learned by now "if there is no obvious answer to a problem, it's probably SELinux."


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.