Certbot failed to authenticate some domains

Je peux lire des réponses en Anglais : Yes

Mon nom de domaine est : rekiel.ovh

J’ai exécuté cette commande : sudo certbot --apache

Elle a produit cette sortie :

Mon serveur Web est (inclure la version) : Aucune idée

Le système d’exploitation sur lequel mon serveur Web s’exécute est (version incluse) : Ubuntu 20.04

Mon hébergeur, le cas échéant, est : Moi meme sur un raspberry Pi

Je peux me connecter à un shell root sur ma machine (oui ou non, ou je ne sais pas) :

J’utilise un panneau de configuration pour gérer mon site (non, ou fournit le nom et la version du panneau de configuration) : non, juste apache de base.


J'essaye actuellement d'avoir un certificats pour mon site mais ca me met une erreur ( voir le screen ), quelqu'un saurait il m'aider ?

Merci d'avance.

Welcome @Rekiel

You have some kind of security protection or redirection feature enabled which is not allowing the HTTP Challenge to Apache to work. When the Let's Encrypt server sends this challenge it should receive the verification token. Instead, your server is sending it some sort of OVH redirection page. Is there some feature to automatically redirect all HTTP requests to HTTPS?

I don't know OVH well enough to instruct how to disable that. But, review your settings. Another option is to use the DNS Challenge but this is often more difficult to setup

Here is more output from a sample HTTP Challenge I made from my own test server:
Note the server is "nginx" so not Apache. This is clue that OVH is intercepting this request or maybe some other network service.

Also note the IP address in the href belongs to Orange and is not related to the IP of my server

curl -i http://rekiel.ovh/.well-known/acme-challenge/TestForum123

HTTP/1.1 200 OK
server: nginx
date: Sat, 06 May 2023 20:01:51 GMT
set-cookie: SERVERID77446=2001710|ZFayM|ZFayM; path=/; HttpOnly

  <meta name="description" content="">
  <meta name="generator" content="ORT - Ovh Redirect Technology">
  <frameset rows="100%,0" frameborder=no border=0>
    <frame name="ORT" src="">
    <frame name="NONE" src="" scrolling="no" noresize>
        <body><a href="">Click here</a><hr></body>

I'll take a look, thanks for the reply

Name:    rekiel.ovh
<frame name="ORT" src="">

Those are two very different IPs.

Also, you might want to include the "www".


I saw this, but I don't know where this ip "" comes from

Alright, thanks for your help.

I just found the problem, it was in the default settings of my domain name -'

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.