NodeJS server Ubuntu 22 on VPS OVH failed to authenticate some domains

Hello community,

every time I run this command: sudo certbot certonly --manual I got this error. I tried everything, I made proper endpoints on my server, refreshing it and still doesn't working.

Certbot failed to authenticate some domains (authenticator: manual). The Certificate Authority reported these problems:
Type: unauthorized
Detail: The key authorization file from the server did not match this challenge "long_string" != "long_string"

Hint: The Certificate Authority failed to verify the manually created challenge files. Ensure that you created these in the correct location.

Some challenges have failed.
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

Somebody knows what is it? Thanks in advance.

1 Like

Hi @InekMarcinek, and welcome to the LE community forum :slight_smile:

I suspect there is something wrong with your web server.
I presume you are using Apache and it has failed you.


It's probably because OVH's load balancers are intercepting the request. See these other threads.

You'll need to find another way (like the DNS challenge) to get your certificate. Or let the OVH load balancer take care of HTTPS for you.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.