Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: animebro.com

I ran this command:sudo certbot --apache -d www.animebro.com -d www.animebro.com

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Requesting a certificate for www.animebro.com

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: www.animebro.com
Type: unauthorized
Detail: Invalid response from https://www.animebro.com/.well-known/acme-challenge/EtYTMRoGc7zSeKY3A032ENoxvdbChCB8pd3cwnUVh-0 [2606:4700:3035::6815:4e69]: "\n\n<!--[if IE 7]> <html class="no-js "

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):

The operating system my web server runs on is (Kali linux):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes):

I'm using a control panel to manage my site (I am not using control panel ):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Welcome @psyco

I see your website is on Cloudflare CDN. Your Cloudflare settings have its edge redirecting http requests to https so your origin server never sees http requests. Thus, the http challenge request you are using with certbot cannot be satisfied.

But, have you considered using Cloudflare Origin CA certs for https between your origin server and the Cloudflare edge? It might be easier staying within their system.


means i just need to change my domain server to my host
from cloud flare and then try to run that programm?

hello i fetched my servers too my home host from cloud flare still i am getting same error please hep

I don't see anything different from when I looked at it earlier.

You are also still getting an error 526 from your https URLs. This means your Cloudflare SSL settings do not match the kind of cert you setup in your origin server. See the topic below on the Cloudflare site for assistance. Note one of the options is to use the Cloudflare Origin CA cert which I mentioned earlier. You may want to consider a self-signed cert too.

I think your problem is with configuring Cloudflare. I think their docs and community are a better option for you at this stage.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.