Certbot: error: unrecognized arguments: --dns-rfc2136-credentials

Everything has been working fine for many months now but I suddenly get an error when trying to renew a wildcard certificate. Help with debugging would be really appreciated.

My domain is: milonic.com

I ran this command: certbot certonly --dns-rfc2136 --dns-rfc2136-credentials /etc/named/certbot.ini --dns-rfc2136-propagation-seconds 5 -d '*.milonic.com' -d milonic.com;

It produced this output: certbot: error: unrecognized arguments: --dns-rfc2136-credentials /etc/named/certbot.ini

My web server is (include version): Apache/2.4.52

The operating system my web server runs on is (include version): Fedora 35

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don't know): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.22.0

The fact the error message also includes the value of the option makes me believe there's something wrong with the space between the option and the value: Certbot doesn't seem to see the option and value separately, but both as a single option.


Why is there a ";" at the end of that command?
[was it inserted into some script?]

1 Like

My apologies, I seem to have omitted the full error message. It was late and I was quite stressed at the time

The full error is:

certbot: error: unrecognized arguments: --dns-rfc2136-credentials /etc/named/certbot.ini --dns-rfc2136-propgation-seconds 5

It seems to like --dns-rfc2136 but nothing after it, it's very odd as this worked fine when I last tried January 22 this year and nothing has changed on the server other than an dnf update.

I have tried typing out the command again but still get the error.

All the commands I use for renewing certificates etc are stored in my "Bible of commands" I simply copy and paste when required.

For some reason I have a habit of adding semi-colon at the end of some lines. Linux CLI seems ok with them so I just leave them in place.

There's a typo in this.

1 Like

The typo is new one, that's an error I made when I typed it manually, oops.

Anyway, I have found the problem.

It seems that I forgot to uninstall an old version of certbot that was conflicting with the newer certbot that runs under snap.

Not sure how it was working before but it looks like I've been updating certificates with old code that has somehow changed recently. After deleting old code and then re-installing snap certbot it's now working again.

Thanks so much everybody for getting back to me, it's appreciated.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.